dspMixFx_UR44 can't find device on my macbook pro


I just bought myself a Steinberg UR44 to use for recording a podcast. I followed to guide and downloaded the Tools for UR44 folder from the Steinberg site. Ran the installation and got ready to test the device.
As I booted the computer and tested the system I found that the headphones had mono only sound. Only sound coming from the left ear.
Then I tried to start the dspMixFx_UR44 software, but it said that it couldn’t find my device.
I tried all common sense strategies. Rebooting the sound card. Rebooting the mac. But it still can’t be found.

The computer speaks find with the card as I’ve tested all inputs and they register in my DAW (logic pro). And of course it plays back the system sound in the headphones.

I have some experience using sound cards as I also own an audient ID22, so I don’t think I’m a complete novice. But something is off.

Would greatly appreciate some help on this one if anyone have had the same experience?

Thank you so much in advance!