Dual Midex8 Win7 x64 issue

I successfully installed a Midiex8 unit.

Later I got an additional unit and moved them both to different USB ports before I booted up.
I assumed that since the driver had been previously installed, windows would automatically install the drivers at the new ports.

I go a driver error message upon install. Windows showed that two ports were not working as they were missing drivers. I uninstalled in device manager and one by one rebooted with each unit booted alone in each usb port. The original unit I had, repeatedly brought back the two missing driver ports in device manager. I tried to reinstall the drivers … which appeared to go smoothly, but when I attached the units, same outcome.

I then noted that the original unit now showed two missing midi ports, specifically 6 and 8 if that makes any difference.

It was ‘Oh, well’ time. So I proceeded with my midex8 and midex6. Then I noticed occasional bleeding into my synths getting midi I didn’t appear to have routed. I also noted that in a fresh, new project without any tracks, when I hit the transport button I would see midi input 1 flashing on the midex6, but not on the midex8.

So just like there must be a pony under the big pile of horse sheet in the stable, there are a couple questions here.

  1. Does this just sound like a unit going bad? I’m just puzzled why it functioned fine on the original install.

  2. Could it be a screw up from not starting the install before I moved to different USB ports, such that somehow the bad driver install is linked to the midex6, no matter which port it is installed in? I do note that they show up with slightly different names in the midi ports list, e.g., the good unit shows port 1 as “midex8[4] 1,” etc.

If so, maybe I need to uninstall the drivers entirely … as opposed to just uninstalling them through device manager in an open windows session. Can anyone tell me if this might help and how to go about completely uninstalling the drivers?

If you read this far, mega thanks!

Como

I’m also interested in this as I just got a new Win7 64 bit computer and have two midex8s I’d like to use. Anybody successfully get two working? Any tips?

-Tom

Using the x64 drivers I have been using two MIDEX8s on Win7 x64 since shortly after my original post.

I have never found away to keep the ports from dropping out of windows from time to time.

When I notice one or more is missing (Cubase will let you know on boot if the port is not found), I either ignore it if I don’t need it for that session or after shutting Cubase do the following:

Right click on my computer and select ‘Manage’
Open Device Manager
Open ‘Sound, Video and Game Controllers’
Right click on the MIDEX8 device with the missing port (sometimes both … you can change their # in the properties dialog to identify which device is which more easily)
Uninstall WITHOUT deleting the drivers from System32
Reboot and they are back.

I’ve never found a predictable way to break the ports, but it does seem that the easiest way to wreak havoc is if by some quirk you send out midi from your synth or device connected to a MIDEX8 1 port … since that will be mirrored to all the other ports (unless you’ve selected port 8 for mirroring).

So mostly it works and I’m very greatful … but I sure do miss my old x86 MOTU MIDI Timepieces.

Como

If Cubase has proper command of the Midex unit, sending a midi signal to Port 1 (or Port 8) shouldn’t mirror to the other ports. That’s only in stand-alone mode.

I use them outside Cubase as well.

I’ve found that there are continuing inexplicable disappearance or ‘drop outs’ of ports. This appears to mainly happen between reboots.

I deal with this in Windows by simply going to device manager and uninstalling the devices (but not deleting the drivers). When I reboot, all is well … for a while.

Just hooked up my second midex8 today. Originally, I had them both running off of a usb hub. This didn’t work at all. Only one could be used. So I tried ditching the hub, and plugging each midex into its own usb port on the computer. BINGO! This worked. Tried it for a bit and it’s working so far. Both midex8s are recognized (all ports).

Hopefully this will continue to work error free.

-Tom

PS - running Win 7 64 bit.