Dual monitors OSX

I’m running a second monitor off my macbook pro on Mojave.

I like running Dorico in full screen mode on my second monitor but every time I start up Dorico it forgets which screen it was on. I can’t get it to open files in full screen on the second monitor, it always goes back to the laptop monitor.

Its a very minor issue, but am curious if there’s a way around this.

1 Like

I think it’s OS related. You could try to set your second screen as the main monitor in MacOS system preferences (including the main menu with the apple icon top left). The full screen mode apps should then open there by default.

Yes, Dorico will generally open up on the display that you specify as having the menu bar in Displays in System Preferences, but in general apps on macOS appear to be quite free and easy about which display they open on, so you might occasionally encounter it appearing unexpectedly somewhere else.

In System Preferences > Mission Control, check “Displays have separate Spaces”. Then right-click on the Dorico icon in the Dock, and under “Options”, you should be able to assign which “Desktop” Dorico uses. (Desktop is the same as “Space”, which you’ve configured to be separate for each Display.)

2 Likes

Thanks for the tips, all.

That worked, though I had to put Dorico into the dock to do it. Haven’t actually used my dock for a couple of years.
And also sorry to take bandwidth here on a clearly non-Dorico issue.

I also have strange behaviour on MacOS Mojave with Dorico Pro. Dorico files always open in my default monitor (my Macbook Pro screen) rather than my external monitor (my second screen) from which I’ve opened them.

It’s a tiny trivial issue. I just haven’t experienced it with any other apps.

I can’t see @benwiggy 's suggestion under Options in the dock.

Thanks.

Screenshot 2021-04-17 at 20.36.10

Screenshot 2021-04-17 at 20.36.27

Hmm. I don’t have the top two of those boxes checked, if that makes a difference.

Screenshot 12

1 Like

Thanks for the suggestion. It didn’t make a difference. I guess it’s a mystery. No biggie.

Oh: you may have to create a ‘second Desktop’ in Mission Control.

Four-finger swipe up to get Mission Control, then click on the + icon in top left.

1 Like

Problem solved. Thank you very much!

Yes, I had to create a third desktop to get the “Assign To” options to appear.

Screenshot 2021-04-18 at 15.42.13

It is also possible to switch monitor focus using Keyboard Maestro on a Mac. See this KM forum article, for example.

The problem has returned despite the ‘Assign to’ option being correctly set to ‘Desktop on Display 2’ after right clicking Dorico in the dock.

I still get the problem on Mojave, but it was temporarily improved by dragging the menu bar to the external monitor within Cmd+Space, ‘Displays’.