[DUPE]Drum-Editor - imprecise positioning of event

When inserting or moving an event (for example a hit) the cursor appears not on the right position. It’s always a bit on the left. So you think you place the hit on the false position. When you drop the event (hit/note) its placed on the right position. A bit nerving but not fatal. Anyone can submit the bug ?

Hi,

My Setup:

  • Win 7 64bits, 16Gb ram
  • C7.0.1 64bits

The issue:

  • Opening a Project from C6.5
  • Editing a midi drum part (recording by a drummer with an electronic drum module)
  • Start quantizing the drum
  • Select a diamon that is not on the rythm and move it with the mouse on the right place
    => it’s impossible with the mouse to place the diamon on the grid, if you want to place the diamond on beat 2.1 for example, the diamon can be only place a bit before or after the beat 2.1, but however when leting the mouse button, the diamond is place on the right place. Not so easy to explain.
  • Ok Now, if you quantize, the diamond will be placed on the grid, but if moving the diamond, you will still get the same behaviour has described above.
  • If doing the same thing but using the Key Editor, it’s work well. The note is moving on the grid.

Does any one reproduce ?

Thanks for you help

I found that enabling/disabling snap and then moving the note did the trick for me.

Did it but still the same issue…

Hi

Mentioned same behaviour here :exclamation:

Was definitely working with CB 6.07 (and is still working).
I think, something got lost during the transition :wink:

Let’s wait for the update for CB 7.02 :unamused:


Cheers

Cross the fingers for 7.0.2 :slight_smile:))

Do you have iterative Quantize enabled?

I’ve noticed that too when Snap is active - while dragging a drum hit around, the “diamond” is always displaced some pixels to the left of where it should be/snap to. Let go of the mouse button and it will be placed properly. Same behaviour with and without quantize. The displacement is always the same number of pixels no matter how much I zoom in/out.

Cubase 7.0.1 32 bit/Win7x64.
Kris.

I’ve this issue on 6.5 too on OSX 10.6.8 and 10.7.5…

It’s desirable behavior in that zoom is improved (and most welcome), however it seems some fine tuning needs to be implemented in the drum map (XML based Editor).

That’s right - this behaviour was introduced in Cubase 6.

Kris.

I did not experience this myself on V6, but likely groundwork was laid for this, i.e. the improvements that inevitably follow; to occur.

I tried it in C6.0.1 before posting.

Kris.

So what about other C6 versions?

It’s the same with C6.0.3 and C6.0.5 - I always backup Cubase before updating/patching. It worked in C5.

Kris.

6.0.7 and above?

Hey, emotive - if you’re so interested why don’t you try it yourself?

Kris.

Even in Cubase 7, while I experience the problem; I am able to work around it.

Ofcourse - it’s just a minor graphical glitch.

Kris.

So maybe it can be filed as an issue?