Duplex, number of copies, forced stems, layout options

Hello all,
Still loving Dorico but have a couple of questions if anyone can help?

  1. When printing a score I select Duplex ‘print both sides manually’ as per the help file but it just prints all the pages out on single pages. Am I missing a setting?
  2. When printing parts I select the number of copies I require of each part but it prints almost double the amount of parts. It doesn’t make sense as some are printed as requested.
  3. When copying music some stems end up the wrong way. I right clicked to select flip stem but it had no effect. I now find that I can select a large number of the notes and choose ‘remove forced stem…’ and it fixes itself. Please can Dorico automatically sort out the stem directions after copying from different instruments please?
  4. I find it clunky when laying out music to keep going back to ‘set up’ so I can select ‘Layout options’ from a menu (to change spacing) but then go back to ‘Engrave’ to adjust frames etc. Could we access Layout options from the Engrave mode too? I don’t doubt the fault is mine but can anyone guide me with correct procedures for layout until the guys cab get us a manual out?

Thank you

For 3, did you import an XML file into Dorico? If so, it’s possible that the XML contained the stem direction for every note in the score (most of which, presumably, would have been the same as the default direction) and Dorico considered that information to be “forced stem directions.” It might be quicker to just “remove forced stems” from the whole score. (With luck, the update coming soon will have a better way to make big selections than current “drag a rectangle with the mouse” method).

For 4, you can leave the dialogs for “Layout options”, “Notation options”, etc, open while you are working on the project. You can drag the dialog windows onto a second monitor, if you have one. If you want to see the effect of changing an option, click the “apply” button.

Thanks Rob,
3. No it wasn’t an XML file so I’m not sure what I’ve done here!

  1. Great!

Thanks again

For 1., I don’t think you are doing anything wrong. In the Print window, I would expect to see the options to “print odd pages only” and “print even pages only”; I can’t see them, but I think they would be what you would need. Neither can I see an option to print a discontinuous page range such as “1, 3-8, 17-22”. Maybe options like this are in the works for a future update?

As a workaround, you could try exporting the whole file as a PDF, and then print duplex manually from e.g. Adobe.

Michael Aves

Hi Davetoria,

For 1: I’ve set Print On to Both Sides Automatically and then Flip Short Side. It works for me
For 2: I think it’s a bug Same issue here
For 3: I have the same problem :slight_smile: Waiting for the update
For 4: Cmd-Shft L will open the Layout Options in every mode. Cmd-Shot E will open the Engrave Options * thanks to hint Daniel*

And Cmd-Shft N will open the Notation options.


Thanks everyone for taking the trouble to reply and help me, much appreciated. ( is there an official ‘thanks’ procedure?)

For the official ‘thanks’ procedure, you can simply click on the thumbs-up icon to the right of the "QUOTE icon that’s at the right of the subject line in each message. A simple click on that thumb-up icon adds the text “These users thanked the author [name is automatically filled in] for the post:” then on the next line it lists the people who thanked the poster and the time/date of the thanks.


I think Davetoria’s problem is that he can’t print duplex manually; your method works for automatic duplexing, but it didn’t enable me to duplex by hand. There is no way in the Dorico print window of altering the printer’s own settings (e.g. printer defaults for duplex printing). I’ve tried altering the printer settings through the Devices and Printers window in Control Panel (Win 8.1), but that made no difference.

Michael Aves

I’ve had the same experience on OSX. It’s as though Dorico doesn’t always communicate with the OS’s print functions It’s not a big problem but it is something one has to take into account.

Sorry, I wasn’t clear in my original post. Michael is right I’m trying to print back to back scores manually as I don’t have an auto duplex printer. The help file says it’s possible but I can’t get it to work. Perhaps one of the Dorico team could shed some light on this please?

Davetoria, when you choose “Print both sides manually”, you should get an OK message box that appears as soon as you start printing. Don’t click OK right away! Wait until all of the pages have printed (which will be just the odd pages), then put those pages back into the printer in the appropriate fashion (exactly how to do this will be determined by the paper path of your printer, so I suggest you try e.g. a 4 page score to start with so you don’t waste too much paper while you figure out which way to put the paper back in). Only after you have put the printed pages back into the printer should you click OK, which will then send the remaining pages to the printer.

The confusing thing, I guess, is that Dorico has to show the OK message box immediately after it has spooled the outer pages, which takes only a moment, but of course printing those pages takes a little longer, and you might expect that you have to click OK right at the start to get Dorico to print anything at all – you don’t. Just be patient, wait for the pages to print, then put the paper back in, and click OK.

Thank you Daniel, I will give that a try. Is the amount of part copies problem a known issue?

Hi Daniel, I tried your suggestion but I don’t get an OK message box when I select print. It just starts printing all the individual pages

I don’t get the OK message box either. Maybe Dorico and some printer drivers are not on good speaking terms?

Ah, I can see a little bug here: it will only prompt you to turn over the paper if you set the job type to “Booklet”, but of course this shouldn’t be a requirement. We’ll see if we can squeeze a fix for this into the forthcoming 1.0.10 update.


Does anyone know if the manual duplex printing works? (Both sides manually)
I can’t get it to work in 1.0.20

I’m afraid we’ve not yet had a chance to fix this in the case that you are printing something other than a ‘Booklet’ job. We will try to get this fixed in a future update.

At version 1.2, this seems to still not be working. Any update? I am trying to print normal sheets, Manual Duplex and get no message and it just prints all sheets in reverse order. There is a workaround (pdf) but it would be nice to get this fixed. If it matters, my printer is a Brother MFC-J6535DW. Auto duplex seems to work fine but it won’t auto duplex on “odd” sizes.

Unfortunately we have not yet had a chance to come back around to this. The forthcoming update will include a fix to the order in which pages are spewed out by the printer when using manual duplexing for booklets, but you won’t be able to use manual duplexing for other job types just yet. Sorry.