Duplicate MIDI track not playing when original muted

I duplicated a MIDI track that has a virtual instrument as FX. Everything seems to have been duplicated. If I mute the original and play the duplicate, I hear no sound.

Now this is weird. If I mute then unmute the duplicate track (even though I can’t hear it playing), voila, I instantly begin hearing the duplicate track???

Hi,

Are you talking about a MIDI Track routed to an Instrument Track or Rack Instrument, please? Do you Mute in the Project window or MixConsole?

Instrument Track muted in Project Window

Hi,

Are the MIDI Tracks routed to an Instrument Track or to a Rack Instrument, please?

What about the following routing? Any Groups involved? Maybe a screenshot might help.

Thanks. I’m a bit of a beginner and routing is still a mystery to me. I just create tracks and play with them. Screenshot attached. When I play the project as per the screenshot, I heard none of the Hi Hat x (D) tracks during playback. Then I muted them and unmuted them. Then I could hear them during playback.

Can you post this same screenshot except select one of the problem Tracks. That will let us see the Inspector for the Track. And then do it another time except this time select the original version of the previous Track - i.e. the source for the broken duplicate.

I recreated the sequence of events.

  1. Attached screenshot No. 01 is the initial state.
  2. Attached screenshot No. 02 shows the duplicated track just after creation.
  3. I then hit play
  4. I hear nothing from the duplicated track.
  5. While still playing, I mute the duplicated track. See attached screenshot No. 03
  6. While still playing, I unmute the duplicated track. See attached screenshot No. 04
  7. I immediately begin to hear the duplicated track.



In your first pic you show the initial Track as being Muted. Is it Muted at the time you duplicate it? And if so what happens if it isn’t Muted when you duplicate it?

1 Like

Thanks, that solved it. If the original is not muted at time of duplication, the issue does not occur. It seems there is a bug in that if a track is duplicated while muted, the duplicate will be muted but the state of it’s mute button will not indicate this.

Hi,

If I understand you right, you do following:

  • Add an Instrument Track, load a sound patch, add a MIDI Part, add some MIDI Notes.
  • Mute the Instrument Track.
  • Duplicate the Instrument Track.
    => Newely created Instrument Track (D) is not Muted (the yellow M is not lithening); but you don’t hear anything.

Am I correct?

I cannot reproduce it here on my side. If I duplicate a muted Instrument Track, the newely created Instrument Track (D) is Muted properly (the yellow M is lightening).

Am I missing something?

Tested on Cubase 12.0.70.

1 Like

Went through same procedure again, this time with an audio track and it worked as I expected and as you found. No problem. However when I do it using a virtual instrument after recording MIDI inputs via my controller, the problem occurs. I play back the duplicated track and hear no sound until I mute then unmute the track. Quite confusing.
In image _05 I hear nothing while playing. I don’t hear the duplicate track until image _07.







Yeah, that’s always been my experience too. I’m wondering if it might just be a display issue where the duplicated Track really is Muted but the button isn’t correctly colored. @enuenu if this happens again try doing something that forces your display to repaint - like changing the Windows’ size.