Duplicating just one audio track causes CPU to max out at idle

Ive got a project that has about 10 midi tracks, feeding Halion 3 and a couple of other VST’s. All plays fine and no issues with dropouts etc.
I have 3 audio tracks. Two guitars and a bass track. The moment I duplicated the Bass track the CPU meter maxed out, as did the one underneath it. This was without me playing anything. I let it sit for about 10mins and nothing changed. Obviously i had no sound, although i could see a few midi inductors flashing when the play head was moving… Deleting the audio did nothing, i had to delete the tracks. Adding them back caused the same thing. Other projects were fine.
I then turned ASIO guard to high (it was on Norm) and that fixed it. At least now I know.

What i cant understand is what everything maxed out like that, without me even playing the track.
My normal latency is around 4ms using the Focurite drivers an do dont have any issues with playing back much larger projects.

Just want to know if this is normal. I see people use 100’s of tracks, mine is very modest in comparison.

Are there any plugins on that bass track?

If yes, it might be interesting to run a few experiments, like
bypassing, disabling, or removing the plugin(s) before duplicating the track.

i.e. in theory it’s possible that a plugin on that track is getting very confused by being duplicated (which intuitively - I would think - would point to a plugin bug). But it might be easy to work-around.

p.s. Audio plugins often process even when the transport is not running or there’s no input signal.

1 Like

Thanks. Thats a good point as there are 3 audio effects on the channel. Only using the stock ones, no 3rd party at all. I hadn’t thought of that.
It seems a bit strange that i cant duplicate a fairly simple track. Earlier i had done the same with the guitar track without this issue.
I noticed even just adding the bass audio in the first instance, with no plugins, caused CPU spikes. This was at idol as well,
Also I noticed that taking that track out didnt help. Things didn’t go back to how they were until i took one of the Guitar tracks out as well.

I recently had a problem where every time I inserted a new plugin - or sometimes even just opening an existing one - the load meter went to max and then no sound any more. I could then fix that with start/stopping.

The reason was the virus scanner, in my case Windows Defender. For whatever reason Cubase10.5.exe wasn’t in the list of processes to exclude from the on-access scanner any more. Fixed that and the problem was gone.
Not exactly the same problem, but a virus scanner definitely can cause serious performance problems in Cubase.

Thanks, i have already taken out all the Steinberg stuff from my AV/Firewall
I tired lowering the ASIO guard back to normal today and got the same issue, this was with the files already in place, so not sure where to go from here, although i don’t see any issues having the guard set to high at the moment.

This is a very odd occurrence indeed.

Maybe a couple of additional avenues of investigation:

  • Are .wav files excluded from AV as well?
  • Is the bass track involved in any side-chaining (e.g. as side chain source for the kick drum)?

Yes, a bit strange.
First off there was no issue putting the Wav file in to CB to start with two days ago, so i assume its in the pool when i come to duplicate it.
All the CB folders, inc the project folders are excluded from AV, as are .wav files.
Its not just these two tracks, its effected all the audio. If i take the guitar tracks out it settles down, so i dont think its specific to the track, its just that it’s pushing the CPU usage over the edge.
No side chaining of any sort as far as i know. Certainly not something ive set up.

oh - that observation is entirely different than what we started with (and the headline for this thread).

Well i did title this thread ‘duplicating one track causes the issue’. And this is whats happening.
After further investigation ive added more info, but the fact is, all was good with 3 audio tracks until i duplicated one. In fact i can add more audio tracks without issue as well.

Tonight i took all the audio tracks out. I added the guitar track back. I created another track and imported the second guitar track (this is the same file as the first, with slightly different processing on the track). I created a 3rd audio track and imported the bass audio. I added back the insets. I created a 4th track and imported the same bass audio and again, put back the insets. So i have everything back as it was, but without using the duplicate function. Going back to ASIO guard and lowering it to normal gave me no issues. I then went on to add two more guitar tracks. All still working fine.
So to me, duplicating ‘a’ track caused the issue. Which it shouldn’t do obviously. The PC has re booted a few times and still when i load that project up with the duplicated track i have to raise ASIO guard, and yet i can lower it with 3 more audio tracks added in the normal way.

Ive also said i don’t think its the wav files, as deleting that didn’t help, i had to delete the track itself, although strangely it doesn’t have to be the duplicated track, but this 3rd track is obviously pushing the system over the edge.

I hope that is clear enough.

Does the problem only happen if you duplicate the bass track or with any track?

Did you check all the plugins you use? Maybe it has to do something with them. Doesn’t seem very logical, but then the whole problem isn’t. Have you tried removing all the plugins before duplicating? If that works, it’s most likely related to a plugin. You could then subsequently add one plugin and repeat until you hit the problem.

I moved on and just set the ASIO Guard to high. It did the trick so I’m just going to leave it like that unless i run in to other issues.
I dont really have the time to fault find if I i have an easy workaround at the moment.
I have been working on another two tracks and have duplicated audio tracks without any issues. Not sure if that’s because ASIO guard is high or not, but everything is working fine so ill work with it like this.