Dynamics becoming stave-selective in piano piece

I’m in the middle of a piano piece (Dorico 4, Noteperformer).

All dynamics are in the upper stave and operating on both staves as expected. That is until a bar towards the end where dynamics placed on the top stave only playback on that stave, the bottom stave remaining at the previous dynamic. I’ve deleted and reinserted all dynamics around that point to no avail.

I can’t see any obvious reason for the change, and I’m wondering whether anyone has any suggestions as to what might be causing this unexpected behaviour.

To get dynamics on only one stave, you need to activate the dynamics popover on that stave while the caret is active, type the dynamic you want, and then press Alt-enter rather than enter. Bottom stave dynamics would appear underneath I think.

My guess is your problem has something to do with this and maybe you’ve done this inadvertently in the top stave which would only affect the top stave.

If you never want the staves playing back at different volumes then you might also check that Independent Voice Playback is switched off for the piano.

Thanks, Daniel. The strange thing is it’s ok right up to this barline. If I delete and re-enter all dynamics around there, the effect is still the same. I was aware of the alt-enter issues which is why I re-entered them. Strange!
I’ll check the Independent Voice setting, but I would have expected that to cause trouble earlier in the piece. This might just be some sort of obscure corruption.

All good. It was worth a try!

If you cut down the project to just a few bars required to reproduce the problem and attach it here, I’ll be happy to take a look.

Your Secondo player is actually set as a Section Player (rather than a Single Player). I’m not sure if that has anything to do with it… but…

I seemed to get around the problem by creating a brand new Piano player (single player) and copying the music from the Secondo to it.

Also, you should upgrade your version to 4.2! :slight_smile:

That’s very interesting. I’ll take a look, although it doesn’t explain why the previous 3 mins of the piece behave normally!

Will check out the update – thanks for that.

Actually when I played the Secondo part from the beginning, the dynamics didn’t seem to work either.

Daniel is correct: the reason the dynamics in the RH staff of the Secondo instrument aren’t affecting the LH staff is that the Secondo instrument is held by a section player. Dorico handles dynamics for instruments held by single (solo) and section players differently, but I think for grand staff instruments it should still be applying RH-attached dynamics to the LH staff as well. We’ll look into changing this in the next update.

In the meantime, create a new single player, drag the Secondo instrument to the single player, then remove the old section player, and that should sort it out.

Thank you, Daniel. However, why do the dynamics appear to work earlier in the piece? At least they do for me!

Much appreciated.


Roderick Elms

I think they just happen to because they don’t deviate much from mf.


Anyhow, it’s sorted. I actually had to copy/paste the stave content across to get it working. Dragging the old piano from secondo to the new single-player instrument in setup seemed to maintain the old behaviour. I don’t know whether that’s useful to know …



Roderick Elms