Dynamics leaving me "molto" annoyed

Does anyone know if it’s possible to defeat the popup’s “intelligence” when doing certain things like inputting dynamics? Case in point:

I don’t want it translating my directions to any other languages, frankly… I can do that myself! :smiley:

Let me check the manual . . . oh wait… :wink:

The way I have done this is to enter the “f” as dynamic and then go into properties and add “very marked” as a suffix. You can set arbitrary prefixes and suffixes in the properties panel at the bottom for dynamics. I have not found a (easy) way to change pop overs or edit the dictionary.

I agree, I think the dynamics popover is a little too liberal about re-interpreting what I input. If I input something like “p ma molto cantabile,” Dorico turns that into “molto p ma cantabile.”

I wish Dorico were somewhat more literal with turning what I type into the popover into the actual dynamic marking.

I use the dynamics popover like Traubitz : only simple dynamics in the popover and then I add whatever I need in the prefix and suffix fields, in the properties panel… until D’s team have time to make this behave more accordingly to my needs :wink:

Yes, that seems to be the workaround… and I’m also looking forward to when this doesn’t need to be worked around! :wink:

It is possible. The algorithm will recognize word boundaries only when there’s a normal space character. Several words separated by a no-break space will be treated as a single word, and thus not be recognized. (I’m guessing wildly here…)
So, in your example, ‘f very_marked’ (_ being a no-break space) will give you what you want.
dynamics with no-break space.gif
I haven’t got a mac, but I think you can enter a no-break space with option-space on iOS.

On Windows it’s a little trickier. You can use this autohotkey script to get a no-break space by typing shift-space (copy and paste the code, there’s an invisible no-break space after Send,):


If you’re not familiar with autohotkey, you can use the attached compiled script. Execute the file and shift-space will happily be a no break space ever after (provided you don’t reboot or shut down the script).
nobreakspace.ahk.exe.zip (512 KB)

On mac, the non breakable space in Dorico is done with Shift+alt+space

On Windows you can type the ASCII Code for a non-breaking space directly into the popover: ALT + 0160

It’s the same on Windows, but here it works only in the lyrics pop-over. Does it work in the dynamics pop-over on mac?

Sure. It’s a bit awkward though. Autohotkey makes it so much faster! :slight_smile:

Well, that worked! Thanks for this, guys.

However, I would still classify this as a workaround, and would be much happier if I could just typing in what I want, without feat of translation services kicking in!