Dynamics vertical position (offset?)

Hi, I’ve run into a bit of a problem after importing a score from xml (Sibelius). Somehow it’s like there is some extra vertical space for the dynamics so they are being too far removed from the staff. Also changing the settings in “Minimum distance below staff…” doesn’t seem to have any effect. It’s the same for new entrances, ungrouped, unlinked, unaligned… Any advice?

Skærmbillede 2021-01-02 kl. 00.40.46

Try selecting all items, and Engrave—Reset Position.

That sounded quite confident; actually I have no idea if that’ll work.

Can you post the project here?

Hi, I tried that already without any luck. Attached is the project (you’ll probably not see the same flags as in the image). Thanks!

dyn-position.dorico (519.9 KB)

It has something to do with the fact that it’s divisi. If I add a new instrument, the dynamics’ vertical position is correct.

Update: Ok, this is really odd. It’s not a “correct” divisi, as far as Dorico is concerned. It’s a single instrument with three staves. That must be the reason.

You’ll need to add another violin, then add a divisi change at the beginning to create three sections. Then copy-paste each staff into the new staves, and delete the old.

More oddities… I have no idea how you have an option to add a new violin in Setup mode with 1, 2, or 3 staves. Did you edit the instruments.xml file?

It’s a remnant of how Sibelius handles divisi. When you import a Sib xml file containing divisis, you inherit these multi-staff instruments. I guess it’s better not to re-use them in Dorico, but use Dorico’s own divisi mechanism, which may involve some copy-paste work.

1 Like

That seemed to work! Thank you so much for your help (and everyone else too)!
All the best and a happy new year!