E-drums: Got events but no sound...

Hi

So, I’ve been meaning to record my mate playing his electronic drum kit for a while and finally got round to it last night.

I managed to get Cubase recording the MIDI events from the MIDI out port of his drum kit ‘brain’ but I can’t for the life of me get Cubase to produce any sound with these!

Look at this pic…
http://www.flickr.com/photos/9332168@N02/5542337395/

It all looks good to me.

Maybe this pic will give a clue?:
http://www.flickr.com/photos/9332168@N02/5542950002/

I can get sounds from a new Instrument Track, and if I click on ‘Edit Instrument’ in the drum track in question I can get sounds out of Halion, just not from the events!

You can see from the screenshot there’s a MIDI track underneath the expanded drum track. This also has drum MIDI events recorded from my drummer but again, can’t see how to get any sound out of the MS GM WaveTable Synth.

(By the way, is it possible to convert a MIDI track to an Instrument track?)

What am I missing?

The MS Wavetable (roland sound canvas) will produce latency, as it routes through the windows mixer so avoid it at all costs.

You need to make an instrument track, eg HALion and both monitor and record incoming MIDI at the same time.

Make sure there is incoming MIDI data via the Transport Bar indicator before recording.

Also ensure to have selected a preset in halion applicable for drums and route the instrument track via the mixer to a VST Connection.

Thanks for your reply, Brains.

Don’t doubt that for a moment! It was just what I got when I tried a MIDI track. How do I route it to something different, such as a VST instrument? I’m not being offered anything other than the MS Wavetable…

Definitely had that going before I hit record.

OK, but my question how have I not got that already…?! I’m not at the drummer’s house now so I want to get what I already have working (which should be much the same as getting it working when I go back, right).

If you are using a MIDI track, create an instrument on the VST Instruments window and route the MIDI output to that.

OK, tried that:
http://www.flickr.com/photos/9332168@N02/5543250909/

You can see in the picture the turqoise bar is suggesting sound output, or that it is at least registering the MIDI activity, but still no sound.

So, I’ve got an Instrument Track with a drum VST Halion Preset with no sound and a MIDI track routed to a drum VST Halion Preset again with no sound. It shouldn’t be this hard!

Turn off input monitor for the track.

Right, I’ve got sound from the MIDI track…by noticing/remembering that I MIDI drums go on channel 10.

D’Oh!

So that just leaves getting sound from Track 1, the Instrument Track.

And now I have sound from the Instrument track. What did it was to switch to ‘No Drum Map’. But that leaves me with a music track. OK, I get drum sounds but when I go in to the editor I don’t see a drum map (obviously) but a keyboard. That’s not too helpful.

There are options in the drum map to ensure that MIDI data is being sent to the correct instrument.

Had to set the GM Map output to the Halion for every drum channel. Bit tedious!

Thanks for your help, Brains. :slight_smile: