e licenser error for cubase le ai elements 9

Hi, please help me for this technical error. Any idea for this case? No license found , the programs will quit now.


Is Cubase activated? What can you see in the eLCC application?

Same problem here since today… Didn’t find a solution to the problem yet :frowning:


Are you on Windows? Try to right-click to the eLCC and run it as administrator. Run Maintenance in the eLCC then.

Can you see your license in the eLCC then? Can you see the Soft-eLicenser number?

I’ve had an issue with the eLicenser for almost a year now; received gear as a Christmas 2016 present and have not been able to license Cubase LE AI 8 ever since. eLicenser software crashes when it’s trying to download the license. Probably been through 3-4 versions of eLicenser, had a support ticket going and sent everything they needed, tried another key (had another piece of gear with similar license).

By far the absolute worst license management software I’ve ever worked with, and I do IT support so we encounter all kinds. I’ve yet to be able to use Cubase LE at all.

Late answer… But the problem can be solved by updating the eLicenser directly from the website. Updating from the app itself will not work.