Earlier Versions

It is possible to load an earlier version of Cubase ?
I have 9.5 so, would it damage it if i installed version 8.5 so i could have both ?

I always have the previous version of Cubase installed alongside the newest version until I’m satisfied of the robustness of the upgrade.

Is it OK to install the previous version or do they have to be sequential ?

You can install any previous version, they’re all completely separate and don’t need to be sequential. My main music PC has SX, Pro 6, 8, 9 and 9.5 FWIW.

That’s great. Many Thanks for the info’

And Projects are both forwards & backwards compatible.

Of course some features/plug-ins that you use in a Project might not be available when you open in a different version of Cubase.