Early Hitpoint Detection

Hello,

Recently upgraded to 6.06. Have troubles with hitpoint detection. Using the hitpoints to detect hits on my snare track, then creating a midi channel based on those hitpoints.

More than 50% of the hitpoints are coming in too early, with no audible or visible reason for where they’re being placed. I’ve tried deleting all hitpoints and detecting again, but no luck. Also tried with different threshold settings, but none of the hitpoints will actually move. I know they can be moved manually, but this project has sessions lasting 6 minutes and over, and the idea of moving all the snare hitpoints by hand doesn’t seem appealing.

I will attach a snapshot I took of the problem. I’ve used hitpoint detection several times before and never had this problem, which was before the 6.06 update if that means anything. Also, in this pic, the threshold is not set in any particular place. I had already tried different threshold places and re-detecting by this time.

Any suggestions would be appreciated!
C6 002.jpg

I apologize for bumping this thread, but I can’t seem to have any luck for this problem.

Am I really the only one having these issues?

Please any help would be great. I have had zero luck with support as well.

-S

This happens to me to, usually not as bad as you are experiencing but enough to make it annoying and time consuming.

We really need some tweakable parameters so we can customise the detection algorithm to fine tune the response.

In the meantime it may be possible to use offline processing on the snare track, ie some eq to tune the track for a better response, like some HP filtering and maybe a little narrow boost at the peak frequency to give the hit point algorithm a better chance of detecting the start point, then once done use the offline undo.

Hi Sparcomarco,

I tried this in C 5.53 - it seems to be ok, all transients (e.g. Snare, etc.) are detected correctly.

I’m planning an update to 6.5, and I hope it’s a …bug (?) which should be fixed in the short term.

Mods / Steinberg?


oh, of course: BUMP!



C.

Just to be clear, it’s not all points just enough to make it a pain, depends on the signal, but some control over the way hitpoints are generated would be nice.

IME this happens mostly where the tail of one hit runs into the next…which is what your screenshot is showing.
(Bad spill could also cause it)

There is a workaround: Copy the track & noise gate it from the process menu

Set the attack & release to 0 & min opening time to something like 20ms, adjust threshold to remove the tails of the snares that are interfering with the detection. Just make sure you don’t completely remove any low level hits.

There is very little bleed on these tracks. They were engineered quite well. I can say that with confidence because I didn’t personally record them!

I’ll try the gate workaround, thanks! I think if Steinberg were to add parameters, they would need to be more like the strip silence function.

I tried this on Nuendo 5.5 and it seems to be giving the same results, in different projects as well.

@Sparco,
please can you attach a .wav of your audio example/s?
I will try this in Nuendo 5.x and Cubase 5.x-6.5/Win7. Interesting, but I feel a bit unsettled!

I’d like to see settings for Attack shape/time and re-trigger time and probably some more that I can’t think of at the moment! Oh and to allow saving of common user pre-sets for quick retrieval :stuck_out_tongue:

So I can “tune” the hitpoint detection to the track “style” I’m sure cubase used to have this at one time, although I seem to remember It was not very reliable?