Eastwest Play 6.1.4 freezes Dorico 3

Hello. Play software got an update that adds compatibility for Catalina and now it appears in the VSTs list in Dorico, but every time I select it to use it Dorico freezes and I have to force quit. Any suggestion?

Start Dorico and have a look in Activity Monitor for a process called VSTAudioEngine. When you select Play, does the audio engine process go away?
If so, please restart Dorico and do Help > Create Diagnostic Report. That creates a zip file on your desktop, please attach here.

Not sure if this can be related, but I noticed that since I updated to Play to 6.1.4, Logic Pro x is crashing every time I choose it as instrument.

I’m not getting that fault, Andre. I’m also on 10.14.6 and 6.1.4.

Yes, the process called VSTAudioEngine disappeared after I selected Play. Heres the diagnostic report. Thank you!
Dorico Diagnostics.zip (356 KB)

The diagnostic report contains two crash logs of the audio engine. Looking at those I can see that not Play is bringing the audio engine down but instead it is Ohmicide-eastwest-funky-VST2. So that plug-in is crashing and in turn brings down the engine.
I’ve attached the corresponding crash log. Please contact EastWest and provide that file so they can work out a fix.
VSTAudioEngine3_2019-10-19-134854_Mitchells-MacBook-Pro.crash (134 KB)

I’m one of the EW beta testers, I’ll pass this on. Can’t reproduce it myself as I an on PC.

@Mitchell: EastWest got in contact with me. The crash is in Ohmicide, a sub-plug-in of Play. They suggest that for a first workaround you move Ohmicide out of the way, it can be found under /Library/Application Support/EastWest/Effects. You will get an alert that the plug is not found, but you can simply ignore it. Then Play should open. Please confirm. Thanks

Gerrit here from EastWest. We got some reports that Play 6.1.4 requires a complete uninstall before if works without problems. On our test computer it works fine by simply installing on top of an old version. But under some circumstances a complete uninstall is required using the uninstaller on mac and the uninstall function on windows. Note: The EW Installation Center doesn’t completly un-install!

Some mac crash logs point towards the Ohmnicide effect within Play. To narrow down the problem you can delete the file from the EastWest/ Effects folder
Please let me know if that helps!

Thanks for coming here to help troubleshoot these problems for our users, Gerrit!

Thank you everyone for the answers! I’m going to try these suggestions tonight and I"ll let you know.

Fixed! I tried first to uninstall everything and do a clean installation but that didn’t fix the problem. So I did the workaround and deleted the Ohmnicide plugin and it works now. Thank you everyone for your help!

Slightly off topic, but relevant: just a note that the exact same plugin (ohmicide) is crashing Logic when attemping to load the Play software…

Hi All, I continue to have problems here. Dorico hangs and has to be Force Quit whenever I choose Play (meaning no crash report possible). I’m working with the latest version of Play (6.1.5). I’ve uninstalled and reinstalled using EW uninstaller and installers. I’m also at the latest version of EW Installation Center. I’ve deleted the Ohmicide. Latest version of Dorico on Mac OS 10.14.6. Any further ideas or suggestions would be wonderful. Since Dorico 3, EW hasn’t worked which is a pity. All best, Kevin

Most likely Dorico is hanging because the audio engine died. Please start again and immediately do Help > Create Diagnostic Report. That creates a zip file on your desktop that shall also contain the most recent audio engine crash dumps. Please attach here.

In addition to Ulf’s advice, make sure you have downloaded and installed the latest version of eLicenser Control Center, which you can find here.

Thanks both of you for this prompt reply. I updated the eLicenser Control Center already as well, so sadly that isn’t it.

Dorico Diagnostics.zip (640 KB)

Certainly there are a lot of audio engine crashes in there…

By the way, I have here Play 6.1.5 running on 10.14.6 and Dorico 3.0.10, and it’s working fine. What if you upgrade to 6.1.5?