Echo sounds effects while recording my synth


I am trying to record one of my compositions to mix down a wav file of it already written to midi scores in Gvox Encore. I’m letting my Fantom(first model) play in multitimbre mode, where all the sound tracks are recorded at the same time in one stereo keyboard track.

There is an echo sound that makes all the sounds faded and resonating, which transform the composition in a faded unwanted way.

Any help on how to record my external synth without the echo with less precision effect?


You have a loop back of some kind going, either midi or audio. very difficult to tell without some routing information. How many tracks are you recording to? Do you have a MIDI track enabled? How are you monitoring? etc…