Edit Active Part confusion

So imagine we have two MIDI parts on different tracks, A and B. We select both with shift and both show up in the Editor, one slightly greyed out. Sweet.

Now, when editing the two MIDI parts simultaneously, and with the Edit Active Part Only activated, I notice that clicking a note on the inactive part switches to editing that part instead. Is this intended functionality? It seems to defeat the purpose somewhat. What I want to do is to edit one part and use the other as reference.

I could not find any settings related to this but maybe I’ve missed something. Is there a way to make the second MIDI part not respond to interaction unless I actively pick it in the parts drop down list?

Thanks in advance


This is as specified. You can switch between all selected MIDI Parts by clicking directly to the MIDI Note of the MIDI Part, as you described. If you want to stay in one of the Part, don’t click to the other MIDI Part MIDI Note.

Thanks Martin.

Yeah, it’s good that it allows switching part by clicking as that speeds up quick editing of several parts. I just expected the Edit Active Part Only button would disable that behavior as it says on the tin.

It doesn’t switch Active Parts when selecting multiple Notes. If you use the Pointer Tool to drag-select a bunch of intermingled notes some in the Active Part and some in the non-Active part only the Notes in the Active Part will be selected. The feature is there to restrict multi-note editing to a single Part. When you select a single Note Cubase assumes that is the actual Note you want to edit and so it switches the Active Part to be the one with that Note.

If you turn off Edit Active Part Only and then select a range of notes it will select Notes in all the Parts.

Yeah, I realize now how it was intended to function. It’s just poorly labeled. It should be called Select Active Part Only then because that is what it does. Editing a non active part is still very much possible with the button engaged. No big deal. Thanks for the help.