Edit Channel Window issues

Hi Guys,

Not sure what to title this as I’m not sure what has happened. When i click on the ‘E’ (edit channel) button either on the mixer or the channel itself it brings up the edit window but it is huge. It stretches about the length of 4 screens, i cannot resize it and the fx,send & fader are all missing. If i drag it all the way to the right hand side of the box there are no strips there at all!

Images attached in case anyone has any ideas!

I’m running 7.5 On a MACbook pro.


Yep, I had a similar problem yesterday but mine wasn’t nearly as wide. I only had triple width sends and faders and I could see everything else too so I could still use the editor.

I didn’t find a solution at the time because I was under pressure to get a session finished. I carried on and once I’d finished it I had to save up and leave quickly so I haven’t tried opening the project again since.

I’ve no idea why or how it happened either, it was a routine opening of the project. (I periodically save, close and re-open Cubase projects because I’m paranoid that during a very long session it’ll start saving corrupt files, which has happened a few times in the past).


I am having the same issue. I can see everything but the VU meter is very wide. I will post a screen shot once I get back to my studio. I had this issue in version 7 and now in 7.5.

Thanks guys. I’ve mailed stein berg but as ever heard nothing, maybe a quick reinstall might fix it!!

What version of OSX are you running?

Sorry that you have problems. Its not funny at all Chris! Its impossible to work like that but its an never ending story with Apple and MAc. :unamused:

Problems with Mac…again…and again… Mac and Apple graphic issues just continues…and its not just on Cubase 7, many other applications, non music too. :bulb:

Contact Apple and ask them why they haven´t upgrade their graphic system so it follows todays modern “standard- specification” as on Windows?

You can try update firmware…

Best Regards

Just thought I’d say that my triple width issue was on Win7x64, so the graphics problems aren’t just on OSX or Mac. (Just updated my sig.)


Thanks Freddie, I’ll see if Apple get back to me, Steinberg clearly can’t be bothered, obviously my £40 upgrade to 7.5 wasn’t enough for them to supply any kind of support!! Time to look into Logic perhaps!

You are welcome my friend! :wink:

Best Regards

This has absolutely nothing to do with apple…

Here’s a pic from my system. Again today I have wide panels on my editor window. It just happens like that about 25% of the time at the moment and doesn’t go away until I restart Cubase.

Also note that some channels in the mixer don’t have panners anymore. I had to create new channels and copy over the audio clips. They disappeared some time between when the tracks were disabled and the project saved, and later after numerous saves/loads when I finally enabled them again. Other than that I can’t say.

And in this image you can see I’ve got some tracks which are missing their EQ/Insert control buttons in the project window. #1 track everything’s OK, #2 track they’re missing, #3 indicates that I’ve definitely got the setting turned on… I think this is also due to disabling and re-enabling them later.


Oh no, it’s getting worse! The width has just doubled again since I closed and re-opened the project (incidentally after a crash when copying a VST3 insert effect across to another channel).

Just as well I’m very nearly at the end of this project…


What graphic card are you using?

I’m on NVIDIA GT 640 2GB RAM. Works perfectly never seen this abnormality.
If you use NVIDIA download and update your drivers to latest version.
Uninstall all old drivers before you proceed.

Best Regards

ATI Radeon HD5450 (4GB apparently), and it keeps itself updated through the Catalyst Control Centre which periodically pops up and downloads the latest versions.

But I’ve only seen this occur in Cb7.5, previous versions worked OK (as do all my other apps).


Hello all,

The only solution I can think of for this strange behaviour, is to delete the preferences of Cubase.
On the knowledge base article you will find the instructions to remove the sequencer preferences:


Best regards,

I’ve got this graphics card,

NVIDIA GeForce GT 750M 2048 MB

I’ll try try the prefs but i’ve already tried uninstalling so who knows!

Any other ideas guys?

Hello chrisunknown,

Based on the screenshots that you posted, you are on a Mac.
On the Mac, uninstalling won’t do the trick as you are only removing the application but the preferences will remain.
Please have in mind that OSX does not have an uninstaller like Windows.
Please delete the preferences.

Best regards,

Tried deleting the prefs and still no joy, the edit window is still at least 4 times the width of the screen. No way of resizing it at all. Hmmm this is very annoying!! :frowning:

Hi GN,

I’ve tried deleting the prefs in the library are there any located elsewhere that should be removed?



Did you delete the folder that says Cubase 7 or just the content inside the folder?
You need to delete the folder.


It is explained on the knowledge base article that I posted above.
You have to close Cubase.
Click on the “Go” Menu on the top of the Mac.
Press down the option key on your keyboard and the library will appear.
Enter the library and go to preferences.
There you will find the Cubase 7 folder.


Best regards,