Edit-in-place grabbing ALL controllers??

Hello,

I was able to replicate this on a few setups, so I’m wondering if it’s suppose to be this way? a bug? Or maybe a preference i’m missing…

So i’m working along, I like to use the Edit-in-Place feature since I can quickly edit midi and keep working. But I noticed something that caused some concern. When you open the Edit-In-Place window on a midi track, you click on the little Grey triangle (upper right corner of the track name area) that gives you some options you get in the Key Editor, specifically i’m referring to the “Auto Select Controllers” button.

So I discovered, with this “Auto Select Controllers” button switched on, it grabs the Midi volume/pedal/etc. when you select a midi note… GREAT! HOWEVER, if you have more than one Edit-in-place window open (which sometimes happens if I’m working fast), selecting a note in one editor grabs ALL of the continuous data in that area and moves ALL of the other edit-in-place information as well!! WHAT!!! why would you ever want this? especially as a default?

It really messed up a whole section for me when I was doing some detailed midi editing, then I go to play it back and like 3 other midi tracks were all sorts of messed up…

My workaround (sorta) is just to not use this feature (or use the Key Editor for complex editing), and if I want to move pedals/volume, I just select them on purpose in the Edit-In-Place… but I’m just curious on the logic behind this…

Is it a bug? A preference? Something i’m misunderstanding?

Thanks for any clarification!

~MH

Yes, I can confirm here, and, I agree, I think the behavior should be changed.
The only “salvation”, currently, is that “Auto Select Controllers” can be activated/deactivate independently for each open Edit-in-place track.
It should certainly only affect the track you are actually editing (and it doesn’t seem to make any difference if you have just the one, or several, tracks actually selected).

Thanks for the confirmation. Since i’m sorta new to Cubase, I sometimes wonder if it’s something I setup wrong…

Seemingly this is a bug… hopefully it gets worked out in the next update. (still does it in 7.5.3)

Well, presumably it has always done it… but I wouldn’t have noticed even now, if not for your post :wink:.In fact, I wonder how many people keep more than one In-Place Editor open at a time? (not that there is any reason why not to, of course :wink: )

You’re right… it’s probably not done often. But for me, I like to see midi parts that i’ve recorded while playing on another midi track. Things like rhythm and chords come in handy to see… Maybe it’s just my workflow.

And also, I’ll have a few open for the same reason of editing midi… so I can see one and look at rhythm/chords and edit in another EIP to match it. BUT I don’t want to move pedals and volume to ALL tracks open…

Like I said, the “workaround” is to just turn off that feature completely… and if I want to move volume/pedals with notes, then i’ll purposefully select the volume/pedal data…

Not a deal breaker by any means, just makes me have to think a little bit extra when i’m in my “Musical mode” in my head.

~MH