Edit In-Place - Workspace does not remember track heights

I’ve set up a workspace that shows two instrument tracks. Both are set to Edit In-Place.
I’ve set their track heights so that they fill the available space vertically.

The workspace does not remember the track heights. The heights become smaller so that one or more other tracks are displayed.

I’ve tried locking the workspace.

I did get this working once (not sure how), but I’ve tried it on a new project and it will not work.

Any ideas?
Thanks for your help.

I’ve accidentally discovered that I can display the correct track heights by choosing the workspace twice:
Windows/Workspaces/Workspace number
Windows/Workspaces/Workspace number

It also works if I press the keyboard shortcut for the workspace twice.

Is this how workspaces are supposed to work with track heights?

Thanks for your help.

Whenever I have had problems with elements of a project such as track heights, I have tried one of the following:

  • Select All and copy tracks/parts to a new project (VST Connections will need to be re-configured and presets assigned)

  • Export data such as MIDI and audio to the native Operating system format, ie .wav and/or .mid and re-import into a new project (tracks and parts will need to be relabeled)

Thanks for your help.
I’ll try that.