Edit Lanes in on multiple tracks in folder with group editing enabled

As stated before, I’ve done a lot of group editing jobs on drums. It’s working here and did through all versions since group editing was introduced. Tried to record a ‘screen proof’ but sadly my screen recorder failed.

The scenario is:

  • multiple takes on lanes
  • group/folder editing needs to be on (of course)
  • ‘snap to zero’ needs to be off!
  • open a single lane of any track
  • using the comp tool to cut (hold alt), not the scissors!
  • clicking any event with the comp tool brings it to front, along with the associated events on all other tracks of the group

Two things can counteract:

  1. The ‘snap to zero’ function - it will cause events to be cut at zero crossing & result in minimal difference of event length throughout all tracks that just get visible on zooming in - this breaks the group as the grouping just treats events as grouped that have the exact the same length. Therefore ‘snap to zero’ must be off when cutting. To check if all events have the same length, toggle group editing on the folder track off/on. If there are different length, Cubase will moan with the yellow message box saying “processing could fail”.

  2. Cutting with the ‘normal’ scissors tool - it will cut just the event you click onto but will not cut through all tracks of the group. Comp tool + Alt (turning comp tool into scissors) is what you have to use to cut through all tracks. Cutting with ‘just scissors’ will also result in a mess of events of different length and break the group.

Hope that helps.

Hi MarQs,
Yes you are right that “snap to zero crossing” should be of. I try to think of it but sometimes just forget it! It is very easy to mess up the tracks that way and loose hours of work. Hence my feature request: viewtopic.php?f=285&t=154763

In my opinion cutting a event with the normal scissor should work also. In fact, in my opinion, any edit to the events with group editing enabled should be applied to the other tracks as well. In my experience this works as long as you unfold the lanes of all tracks in the group, which is taking lost of time, workspace and energy!

The only way for a rock solid group editing function is in my opinion that all edits, no matter what tool is used, no matter the lane is closed or unfold are always applied to all tracks in the group. Snap to zero crossing should be neglected for tracks with group editing enabled.

Probably you are right that in theory group editing works (if you work within the very strict conditions to make this function work) In practice it becomes almost useless and you have to constantly check whether the group editing works as expected.

+1

Scissor cuts, beam selections and delete, select and move with arrow tool. ALL of these functions and edits should remain in sync when folder sync is enabled. There should be NO way to BREAK sync within a folder when folder sync is enabled. The comp tool is inadequate and an unnecessary tool in my opinion. All of its functions can be more easily carried out with normal select, scissor cut, mute and glue operations.

Scissor cuts, beam selections and delete, select and move with arrow tool. ALL of these functions and edits should remain in sync when folder sync is enabled. There should be NO way to BREAK sync within a folder when folder sync is enabled using any editing tool from the menu. The comp tool is inadequate and an unnecessary tool in my opinion. All of its functions can be more easily carried out with normal select, scissor cut, mute and glue operations.

Is anyone taking notice of this longstanding issue Steinberg? Haunts me every single day and every project

Absolutely! This has been an issue for years.

That’s about the only scenario in which group editing works properly when some lanes are collapsed (alt cut with comp tool). Swiping with comp tool fails. See screengrabs:

In this image, I have 4 tracks in a folder with group editing enabled. One track has lanes expanded.

I swipe with the comp tool to select a part on the second lane. Inexplicably, no cuts are made to the events on the other tracks with lanes collapsed.

I expand all lanes, toggle group editing to get the dreaded “tracks in the folder are not completely in sync” popup.




Slip editing with the comp tool gets messed up too if some lanes are collapsed (holding alt+ctrl while dragging horizontally), although this has the potential to go undetected for longer and really screw up sync, as cubase won’t complain when one toggles group editing.

This is not really a feature request - it’s an “issue” (euphemism for bug) which has not been fixed for years.

Can we have this moved to the ISSUES forum please moderators?

Just installed Cubase 10.5 and this is going on still. It’s very annoying, I can’t comp a group unless all the lines are opened, it doesn’t make much sense to be honest.

The weird things is that over the years I’ve worked on different Cubase set-ups and in some of them it behaves like this and in others it doesn’t (I think?) meaning that you can comp a whole group without having all the lanes opened.

I’ve been reading the manual as I though I must be missing something but I can’t find anything so far. Anyone?

+1. The current behavior breaks itself

Still I don’t get it why it doesn’t work for you complainers. As mentioned before I’ve done group editing on drums a zillion times. Obviously I have super powers as I did and do tight work with a supposedly broken function :mrgreen:

The kind of picky behaviour with event length and the zero-crossing-pitfall are bothering and unnecessary in my eyes - could definately be improved. But once you know about them those two guys are pretty easy to sail around.

What’s wrong with cutting using comp tool + alt? It works through all lanes no matter how much are expanded. Clicking any piece of a take on any tracks’ open lanes with the comp tool makes it the playing piece of audio throughout all tracks. Mission accomplished. I just can repeat that it works.

:question: :exclamation: :question:

Hi marQs, I don’t understand it either, hence my comment.

As I stated in my previous post I know it’s supposed to work, but out of the 3 systems where I work it does work in one and not in the other 2. The most recent one is a clean install just done a few weeks ago in a computer where Cubase was never installed before. Yes I have zero crossing off and the even length is the same and it hasn’t been edited at all.

So my guess is that
a) There is a preference somewhere that I’m not aware of that it’s causing it (not zero crossing)
b) It just doesn’t work properly

Yes I use this very often and yes it’s a total pain to have to open 16 channels of drums in order to comp, which I have to go one by one.

Aside from this, I do agree with everybody that I’ve always felt that the way group editing works in Cubase is unreliable, you need to be very careful with not editing/cutting anything or it will go out of sync and once it does the whole thing becomes a mess.

I’m sure there are workarounds that I don’t know of but group editing should be very straight forward in my opinion.

Every single use of folder tracks messes up for me within minutes of editing marQs. I’m a daily 10 hours a day pro studio user. Zero crossing off. Sync on folder form start of use. Using all editing tools (scissor, arrow, drag boundaries of parts).

My observation is that the bug is in front to back stacking - it somehow allows one or two tracks in a group to be treated differently when a scissor cut is made depending on the lane stacking. From that point folder sync is broken.

Note too I tend to do most of my editing with lanes closed or the first lane in a group only open. Its the only way I can organise the screen in a 18 mic drum folder for example. 10.5 … stil the same since maybe Cubase 6 or 7. Cant remember anymore.

I’m not aware of anything, but I’ll take a fresh look to the preferences. Most of them are set since forever.

In case preferences matter, you could try saving them from the machine where all works as expected and loading them on the other two for testing if it makes a difference.

Addition - here are my current and working C10.5 preferences to test:
https://www.dropbox.com/s/r28vp5iesggyyih/marQs%20C10.5-05.xml?dl=0

Just found this thread which I’m glad to see reveals that I am not going nuts - I’ve not personally had any Comp Tool issues when editing grouped tracks in a folder .

But tonight I found an apparently v. similar issue with sync loss between tracks in a folder groups…

My scenario: I am tracking a 12-channel/track multi-mic drum session with all the mic tracks in a folder together. When I went to audition my various takes I could hear all sorts of weird flamming on the drums. At first I thought I’d just fluffed the take (even though it felt good tracking it!) so I skipped to a different take in the folder group - same thing.

I’d had only the first track’s lanes ‘expanded’ for the very same reasons as other posters - I only need to see the first (in my case, kick mic) lanes just to verify that I’ve been recording OK - so I’d left all the other tracks in the folder with their lanes un-expanded to de-clutter things massively.

When I opened up all the other tracks, I noticed that the ‘S’ (the indicator/button to select a specific lane for playback was completely out of sync from my kick track and the others - so on the kick mic I was listening to (say) take 6, and yet the other newly-expanded lanes were playing take (say) 8.

Hence it sounded like crap. When I expanded all lanes, the sync of the ‘S’ button started working all OK again. I didnt get the dreaded ‘Group editing might fail’ message at all when testing to see what would happen if I de-and-re-selected the ‘=’ Group button - all the tracks’ events are OK.

But this loss of sync just wasted me a lot of time to figure, complete workflow breaker and obviously a buggy bit of programming. I’ve been a Cubase user since Pro24 and as such have got a lot of time/effort invested in the program which makes me want to remain so. But this is just poor, and really disappointing. I would log a call with Steinberg but over the past few years have found their support to also be sadly lacking (2 hours a day on some day, phone call to Germany, no response for > 1 month for last ticket…) so if anyone has a route to get this logged as a bug then I’m more than happy to +1 any bug fix post anywhere.

Hope the above is useful for someone,

David

nightmare to scroll up/down etc.

Yes, please!

This is really about time Steinberg sorts this Bug out. The grouping of Audio editing should never be broken. I find the Lane editing hand tool is the culprit for me, I never use it ever as it’s function is utterly broken in group editing. I do Drum editing daily. Wake up steinberg no more fancy plugins fix the BASIC functions.

Hi, I would lie to point Steinbergs attention to this issue again. It is a basic and very important function. Group editing should be rock solid! Tis is costing me a lot of time.
On Cubase 11 I still experience a lot of problems in group editing. Please, please please, please, please please fix this!
It would be a dream if I can do al sorts of edits on the lanes of one track and keep the lanes of other tracks in the group unexposed and not have to worry about losing sync!
Also for my customers, to see me doing a simple edit on the drums, having to expand all lanes (lane by lane), it surely does not look as Cubase is a professional DAW! (which it is in all other area’s)
Please make group editing rock solid!