Edit->Remove Rests only removes some rests

As you can see from the attached project file and picture, after using Edit->Remove rests I am still left with a few rests, immediately following some grace-notes. The rests also appear to be changed to explicit rests. I’ve tried using begin voice/end voice and other things, but nothing seems to work for me. Any suggestions much appreciated!


PopperEtudes - 9g.dorico (385.5 KB)

Grace notes have to be attached to something real, in the same voice, essentially.

You could select those rests, custom scale them down to 1% and set their opacity (color transparency) to 0, effectively making them invisible.

1 Like

Thank you, pianoleo, as always :slight_smile: Much appreciated!

1 Like

(Just make sure that when you print/export, you do so in “Color” not “Mono” as the opacity setting needs “Color” to work iirc)

1 Like