Editing Note Expression

Hi good people. I have set up a Note Expression Input Device for my Haken ContinuuMini, and i can record it’s MPE data into a MIDI track in Cubase. I can play that track back into the Cmini, and it appears to reproduce perfectly what I’ve just performed. But editing in the Key Editor is currently not working correctly.

In the Inspector for the track, Note Expression is enabled, and MIDI as Note Expression is ticked. In the Key Editor, Show Note Expression Data is ticked. But in the Note Expression Inspector window, only CC1 (Mod) is showing. If I try to select Make All Expressions Visible, nothing happens. Show Only Used Expressions is the only option I can select here, and it’s not showing the controllers I’ve used, only CC1 (Mod).

So therefore, in the Key Editor, the only Note Expression available is CC1. Whereas there is no CC1 recording, it’s typical MPE data of pitch-bend, aftertouch, and cc74, 87. If I open the List Editor, I can see that in fact, what has been recorded is pitch-bend, aftertouch, and cc74 and 87. But I can’t see that as Note Expression in the Key Editor.

Clearly I’m missing a crucial setup step. I had this working last year, so I know it’s possible. How do I get the correct MIDI controllers to show in the Inspector Note Expression window, so that I can edit MPE data in the Key Editor?


I assume you have made these controllers visible in the MIDI controller set up?. Same menu as ’ Make all expressions visible, right down the bottom.

Here’s what happens when I open a new empty Project in 10.0.

  • The Note Expression Input Device that I set up last week has disappeared (even though my ContinuuMini is still recognized in the inspector as Available for regular MIDI in and out), so I go to Studio Setup and create a Note Expression Input Device, with settings for Aftertouch, Pitchbennd and cc74 “as recommended by instrument”.
  • In the MIDI track Inspector, I set the Note Expression Input Device as the input, output to Any, further down I enable Note Expression and check MIDI as NoteExp. All controllers are visible in this Note Expression area. Do I need to check the ones I want? I check cc74, Pitchbend and Aftertouch anyway.
  • I record from my controller. If I look at the List Editor, I can see that Pitchbend, cc74 and Aftertouch have all been recorded.
  • I open the Key Editor, and check Show Note Expression. In its Inspector, all those controllers are still checked. I click on a note to open the Expression Edit box, but there’s nothing there. In the Parameter Selection, bottom LH corner, it says: No Parameters Used. All the controllers have been recorded as regular MIDI data, and I can see them in the regular cc lanes underneath the Key Editor. But that’s not polyphonic MPE Note Expression data.

No Parameters Used in the Note Expression Editor. Where am i going wrong?


All sounds very complicated. You do have the Pitchbend box checked (colour filled) not outlined?. see pic
May I suggest creating Pitchbend in the controller lanes then using the ‘Convert to note Expression’ function.
Capture 2.PNG

“Convert to Note Expression”. That’s it! That’s all I needed! As in, select the part, go to MIDI > Note Expression > Convert to Note Expression. Such a little thing.

Since I am recording with a device already set up in Cubase as a Note Expression Input Device, and all the correct checkboxes are ticked in the Inspector, I naturally assumed that Cubase would automatically record MPE MIDI as Note Expression. In fact, I can’t understand why it doesn’t.

And you’re right, it shouldn’t be this complicated.

But thanks so much, J Buckingham, for the simple little nudge that solved my issue, for the moment.