Editing notes in the Key Editor - double notes

When I click with the arrow editor on the end of a note, to drag it and thereby shorten or lengthen it, the note is cut in two parts, with one part being the part the was deleted or added. How can you avoid this, in other words, that the note is NOT cut in two parts?

It could be that all your midi notes are doubles, as in there is 2 notes on every spot with 1 hiding behind the other. Try to create a new midi event and just draw in a single note and try if it does the same.

Thx, they were doubles indeed! Now I have to figure out WHY they are doubles.

Under midi menu --> functions there is an option to delete doubles.

Can very easily happen, you have a midi loop somewhere.
Depending on how your midi keyboard is setup, (local on or off)
And if Cubase is set to midi thru in preferences, there can be different causes/solutions.
Try to find a solution that fits your way of working.

Check out the menu Studio->MIDI->MIDI Port Setup, you may find that your midi input has 2 entries in this list so you need to disable one of them. Also check the tick boxes at the bottom of the window. I have unchecked the Use Device DirectMusic option, and in my list I only have WindowsMIDI devices.

Mike.