Effects Plugins shows only Generic Editor and can not switch to Plugin Editor in cubase last update

Since I upgraded to cubase 12.052 on my windows computer the steinberg Effects Plug in editor dissapeared. I only have the Generic Editor. Also my Meter info dissapeard. I want to see the plug it’s self and not the parameters. That’s confusing and the worlkflow is ignored.
On my Mac laptop there is no problem with that? Than it works and I can choose if I want th epLug in Editor or Generic edior. I asked Steinberg for support and the suggested to refresh al the preferences etc. I did that and lost al my stettings and keyc commands and the problem isn’t solved. So that;s not the solution. Is there somebody who knows what I must/can do. Thanks a lot!!!


What happens, if you Switch to plug-in Editor?

As you are on Windows, I would try to reinstall Cubase. Make sure, you install it as administrator, please.

Must I re-install cubase 12? or the update? What’s the best way to remove cubase 12? What do you mean as Admistrator? And if I Install everything new do I also have to install all other content like samples, instruments etc?


It’s OK reinstall just the update.

You don’t have to uninstall it. If you would uninstall it then install Cubase, not the update.

Right-click the installer file and choose Run as Administrator, please.

You don’t have to reinstall everything in this first stage. Try to reinstall just Cubase, please.

Ok I wil try that. Thanks a lot!!!
If there are more suggestions. please let me know.

Yes it worked. Evetything is back on his place. Thanks Martiun!!!
But the strange thing is that the support of Steinberg gave me the wrong options and that’s why I lost al my Preferences . key commands etc. But that’s not the end of the world. Its okay now!!!