Eh, why does the app flash?

Yes, sometimes it will flash as I hit record. And then why does the track screen black out like it does, sometimes in sections. Is this a feature of the app that is trying to save my iPad battery usage? Can I stop this from happening? The app works very well inspite of all the flashing and black track areas, BTW. It just looks like something is wrong, eh?



sorry, but we are not aware of such an issue. Could you provide us with more information regarding your device, iOS, Cubasis version and other gear? Also if possible a step by step description for us to reproduce?

Thank you!

Hm, really? OK, glad I asked about it.

I am using an iPad2, the latest Apple iOS (7.1.2), and also the latest iC Pro version(1.2). In short, everything is up to date.

I just tried the iPad right now while sitting in front of my DAW. It was working fine on the main ‘track’ window while playing back and recording - UNTIL - I clicked on another window within the iC Pro app, going to the ‘UNDO’ button, and clicking it to remove two recorded tracks that I had just recorded, and then returning to the project track window again.

I think this is what set it off, leaving the main track window and returning. At this point, the flashing started just like it did when I was tracking the other day - AND, BTW, THIS WAS EXACTLY HOW I WAS ROLLING THAT DAY, OPENING ANOTHER SCREEN AND CLICKING ON THE ‘UNDO’ BUTTON. On both occasions, a few days ago and today, the project still behaved as it should on the DAW, and I was flying blind on the iPad.

Do you want a video on this? My wi-fi coverage is exceptional here so I don’t think it has anything to do with that. I can’t be the only one this is happening to.

Next I will try it on my iPhone and get back to you.

OK, I just did the same thing but now using my iPhone and the exact same thing happened, flashing screen. At this point I suggest this is a bug.

The funny thing about my apparent singular complaint in regards to this behavior of the app is that I think this is pretty normal behavior while tracking - to record something, deem it unworthy, delete it, and start over. If I kept all the bad takes I can assume this would not happen? Ha, this is not me. I hope you can sort this out.

I sometimes get the same thing, usually when I try to use one of the commands I created (transport>return to start position on stop almost always causes a black or flashing screen). john.

Ricardo, were you able to duplicate the issue I reported?


we are investigating on it… I get back to you asap.


Ricardo, you must be busy. For now could you just confirm for me that you can duplicate the problem?

I hate to say it, but I am always amazed to see how few people use this app. There cannot be just two of us that have encountered this problem.


sorry to have you wait… but no, at the moment I can not confirm it. You offered to send me a video, I would like to take you on that one. Please film the scenario and send me a PN with a cloud link to download and I will share that with the team.


Ricardo, here: - YouTube

Not the best quality video but the problems I am encountering should be obvious. And I have to add, I am amazed you are not able to duplicate this on your end. Me thinks you have not tried, eh? :laughing:


thanks for the video… tried it again myself and still not flashing here, sorry :frowning:. But I will have the other guys have a look at your video and see if anybody can find a solution. At the moment some are on summer vacation though, so please hang in there with me. Sorry again for the inconvenience. I would like to collect more information about your chain of connectiont. What is your router and have you assigned manual IP numbers to your devices? You mentioned the same happen with your iphone so we can clearly say it is not a hardware defect on the ipad.


Wow, that’s, well hard to accept that you can’t duplicate this, and mostly because it is completely repeatable here. Haha!

OK, my router is a Netgear R6250 and my my IP address(s) was/were assigned by the app, no manual entry.

Hi Ricardo. How about those vacation folks? Have they returned yet?

Also another question? Should my ipad and my iphone use the same ip address while running iC Pro?


sorry no, I have not heard back yet… if by any chance you have another computer or lan router around to test with, let us know. But of course dont stress to change your running system.

About your IP question. Each device in a network must have an individual IP number, so you can not share the same. You would get an error message.


OK, weird thing. I did fire this up on my old network via my iPhone and it seemed to work just fine. However, I ditched that network and reestablished connection to my new one, Netgear. However, now the iC Pro is glitchy, with the screen going by in a jerky manner. I can record, go back to the Commands screen and ‘Undo’ the recording, return to the project screen and the app does not flash. Unfortunately now the app is unusable for another reason, the jerkiness. And keep in mind the old network has no range.

At this point I think all that has happened is the app is ‘confused’. Haha. Me too.

So what do you make of this? I think this is beyond strange that an app can be network impaired.

Alright, now I’ve come back to look at this again more carefully. I can report that I am back to square one with the same flashing as before. HOWEVER - before, when I had my iPad and iPhone connected simultaneously, if one app would flash then the other one would also flash. Now it seems the flashing is isolated to the device from which the UNDO button was pressed. Well, for a short time anyway. At one point I had my iPhone flashing and doing the black screen thing, but the iPad would look normal. This is most bizarre. IMO.

I should also note that I manually entered the IP address on the DAW into the app. Also that my two devices have separate IP addresses for themselves. I should also add that I am using my ‘Home Network’ and that the Windows Firewall is turned off for it’s use. I also have Cubase 6 enabled for programs that are able to be accessed to the network. I will also add that there are duplicate entries here, as in there are 2 Cubase 6s, etc. They are all clicked, redundant or not if they pertain to Cubase.

Alright, more input…

I went to my USB attached WiFi Network adapter, double clicked on it and then went to the advanced tab. There are 5 lines (Properties) that pop up starting with ‘802.11b Preamble’. The third property is ‘Receive Buffers’ and the fifth property is ‘Transmit Buffers’. As you click on these two items, a value number will show up in an adjacent window. Both of these values were ‘64’ - the highest value they can be. Drawing from my WinXP tune-up experience, I learned that reducing this number, lowering the value, will increase the importance of the event and typically cause Windows to ‘refresh’ this item more often. In Win7 I was told you cannot control this function for any device, so I was surprised to see this in my adapter window. But I believe my thinking here is sound. In XP you could lower the value of all the devices, making you video card more ‘important’ than what XP would typically ‘value’ it at as it was initially installed, for example.

OK, there is an 8X numerology here to abide by so typically you want to end up with a number that is a multiple of 8. So 8-16-24-32-40-48-56-64 are the big divisions. Anyway, I changed both numbers to ‘32’ and repeated my tests of the iC Pro. And here’s the good news, my iPad seems to be responding very well without the extreme glitching behavior it was displaying. Too, I can record, click the 'Undo button, and my project screen will not flash or go black in places. Things actually look good. :slight_smile:

On the other hand, my iPhone still behaves the way it did, with the flashing and the black sections of the Project - all caused by visiting the Undo button. Another plus here is that the iPhone behavior does not transfer over to the iPad like it did either. Now the two devices are more independent.

Thoughts, Ricardo?

Ricardo, I’m checking in. Has your group looked at my problem? It would be great to have my iPhone working properly.

I do think my problem is network related, however I do not think there are any warnings or preferences as to the Wi-Fi router I might choose to use. How exactly do you go about developing this app? Is there just one Wi-Fi router that you use or do you intend that it work with any Wi-Fi router? Netgear is a very reputable company and makes a great Wi-Fi router. It would be a shame to think that any of my issues with the app are caused by the Steinberg app writers failing to include the Netgear product. Is my Wi-Fi router that unique? :question:

HI again,

I had a bunch of guys trying to reproduce the issue, but nobody could so far unfortunately. So at this point I have no answer for you. :unamused:

Thanks anyways!