eighth = eighth -- font changes in text?

Hi,
I apologize if this is covered elsewhere, but I searched a few different ways:

I want to put in an eighth=eighth (sempre) indication (changing meters from 3/4 to 3/8 or 6/8). I tried as text (shift-x), but the font change that I seem to remember being there is gone? Or am I not looking correctly? I also tried pasting from the SMuFL characters, but just get a blank. I tried putting it in as a tempo (e = e), but that shows up as letters, not notes.

I also don’t see in shift-x any way to change sempre to italics.

Anyone know what I’m doing wrong?
Thanks,
David

You can type ‘e = e sempre’, then select both e’s in turn and change the font to e.g. Maestro (if you have Finale) or some other regular music font where e is mapped to an eightnote. Then select the sempre and change it to italics, upper right where it says ‘regular’ by default. You can adjust both the font size and the baseline of indiviual characters…

In the Bravura font the e isn’t mapped to an eightnote, so you have to copy from here: http://www.smufl.org/version/latest/range/individualNotes/ and paste into the text panel…

Thanks! I didn’t se the change font because I needed to scroll down!

When you paste into Shift+X text and want to use Bravura, change the character style using the top right-hand menu in the text editing popover, from where you can choose ‘Music text’.

Thanks, Daniel! Fratveno’s way works more quickly, but your way is purer Dorico, perhaps worth the effort in anticipation of upgrades that will allow this kind of thing more effortlessly.

You can type ‘e = e sempre’, then select both e’s in turn and > change the font > to e.g. Maestro (if you have Finale) or some other regular music font where e is mapped to an eightnote.

Specifically how do you change the font? I can’t find a way to do that.

And to be clear to anyone else reading this, the problem is that while q = 144 gives a quarter note symbol as expected, q = q., which is what I need, only gives you q’s, not the note symbols.

OK, in the few minutes since I posted the above, I’ve found some other inconsistencies. When I entered Piu mosso q = 92, the q = 92 was just dropped, leaving only the Piu mosso.

At this point, given that some entries work fine while others don’t, I’m thinking bug. Still, if anyone has any help to offer, I’d be grateful.

When you type shift-x, you get a popover box. Fonts are at the top left (Academico is preselected). You can also adjust size and style also, plusany details of appearance.

Thanks, dfroom. Unfortunately, that’s not what I see in my popover (see attachment.) There is the little q=72 symbol, as you can see, but it doesn’t respond in any way to clicking, double-clicking, or control-clicking.

Am I misunderstanding something?
TempoPopover.png

Try a text popover, shift-x, not a tempo popover. The tempo part of Dorico isn’t fully baked yet.

Actually, alt-shift-X would be better, since it creates System Text which will appear in every part as well as the score.

The “q=72 symbol” is just a label showing an example of a tempo mark, to tell you which popover you are working with (that’s how we know you typed shift-T not shift-X).

Thanks, DAVID and Rob.

I didn’t know about the system text option; I only knew about the staff text. That does sound like the answer.

I’ll try it out as soon as I get back home.

OK, guys, it worked exactly as you said it would — thanks.

Is there a way to set the default font for Text and for System Text? I went through every settings page I could think of, but I couldn’t find them. It would save having to change the font size every time I put one in.

Thanks, as always.

If you go to Engrave > Paragraph Styles you can change the font for ‘Default text’.

Does anyone know if this can work on Mac? I tried opt-shift-X, cnt-shift-x, cmnd-shift-x. None of them does anything except give me a “can’t do that” beep. I WOULD like for my e=e sempre to be a system entry, to appear in each part. Is there another way to do this?
Thanks
David

Have you reset your key commands after updating to 1.1?
New key commands won’t be added automatically to your configuration, so you’ll have to add them manually or do a reset.

Anyhow - ‘System text’ should also be available from Write -> ‘Create System Text’

Yes, I’m using it on my Mac. However, to get it to work, I had to enter it manually. To do so, go into Preferences/Key Commands, type System Text into the Search field, which brings up NoteInput/Create System Text, and then assign the Opt-Shift-X keystroke (or whatever you want—I used a different keystroke) to Create System Text.

The fact that you get a “can’t do that” beep when you try to use it makes me think you may have Opt-Shift-X already assigned elsewhere. If so, when you input that keystroke to trigger Create System Text, you’ll get a message telling you where it’s already assigned, so you can deal with it.

Daniel wrote in another thread that right now, any new keystroke commands issued in version updates don’t go into effect for users who have already assigned even one keystroke command of their own (I have many and had to deal with this.) It sounds as if you may have at least one that you’ve assigned, so none of the new keystrokes the Dorico team included in v. 1.1 will be in effect; you’ll have to input them yourself. He said that problem will be addressed in future version updates.

[Sorry—Andgle answered this part of it while I was still typing.]

Hope this helps.

Ah, I see. Yes, I reassigned a number of keystrokes. To make the learning curve less steep, I remapped as many of the keystrokes to the Finale equivalent – particularly note durations during note entry and enharmonic flipping. I was really happy I could do this.

I was able to create opt-shift x to enter system text. Nice to know about this.
David