Elements 6 - Halion se - midi won't play - midi virgin

I’m an audio guy and guitarist/bassist/singer and I have NEVER worked with MIDI in any software…I’ve ALWAYS been in analogue…

HOWEVER, I need to extract a midi drum part for a particular song and export it to my new Beat Buddy.

I’ve been able to play and HEAR the .mid file using windows media player.

I’ve been able to import the midi file to Cubase Elements 6. I can hit play and see the meters move but THERE IS NO SOUND… The outputs for each instrument are outputting to the Halion SE device…

There are NO “midi devices installed” in Cubase and I haven’t got a clue which one to pick…Halion SE ain’t on the list…

I have NO idea what to do next and the manual is no help – I’m NOT a MIDI guy and obviously don’t grok the vocabulary…

HELP!?!?!

Can anyone help me with a step by step explanation of how to get MIDI to Play…

Here’s a screenshot of the midi file in Cubase:
http://chetgardiner.com/MidiInCubase.jpg

WILL SOMEONE HELP ME!!!

MIDI PLAYS IN WINDOWS MEDIA PLAYER. METERS MOVE IN CUBASE WHEN PLAYING…

BUT NO SOUND FROM MY SPEAKERS…

WHAT PART OF SETTING UP CUBASE TO PLAY MIDI AM I MISSING???

THE MANUAL IS HOPELESS. THERE’S NO STEP BY STEP INSTRUCTIONS IN THE “KNOWLEDGE BASE”…

I FEEL QUITE STRANDED AND IGNORED!!!

:frowning: :frowning: :frowning: :frowning:

Ok… You said you imported a midi file into Cubase. So now you are seeing it (I hope) on a midi or instrument track but can’t hear it. The midi file itself does not contain “sounds”. You need to assign what sound you want the midi to play.

Apparently you do have an audio interface set up with Cubase so most likely the problem is that you need to assign the vst instrument (Halion Sonic) to the midi (or instrument) track that the midi file is on AND choose a sound from the list of sounds available in Halion. Also, you need to make sure you activate Halion. These assignments and settings are accomplished in the inspector section.

By your photo I can’t tell which track you are having trouble hearing.

  • Make sure the midi is imported to a midi or instrument track.
  • Click on the square shaped button (to the right of the “2” in your photo. That will open the Halion control panel.
  • Choose a sound from the sounds available in Halion.
  • In the Halion control panel, activate the sound by clicking on the activate button (upper left corner of Halion I believe). It should turn blue when activated.

Hopefully you now are a happy camper.

As far as the “no midi devices”. That should be no problem because it would be associated with a midi device (like a keyboard) if one was connected to your computer to actually record midi. Apparently you don’t do that… Yet.

If you still need assist please make sure to list all of your computer, hardware, software specs.

Regards. :sunglasses:

Thanks for your reply…I don’t feel quite as alone any more…

This must be something super-stupid simple – the kind of things I had to break through to get AUDIO to play oh, so many years ago…

I’ve posted a picture of Halion as I’ve configured it for this midi file here:
http://chetgardiner.com/HalionSonicSE.jpg

EVERYTHING appears to be working. When I play the tracks I get volume levels next to the channels in Cubase, lights lite up in the Halion control panel,

I also get level in Cubase when I click on the keys on the piano keyboard in the Halion control panel –

EVERYTHING pretends to play except there’s no SOUND from my speakers.

Here’s my (suspicious?) VST Intruments display. Halion is there but do I need to ALSO add instruments in what I can only suspect are MIDI channels?
http://chetgardiner.com/VstInstruments.jpg

Nope, that ain’t it – only adds another Halion channel to the project…

Here’s my MIDI Port Setup:
http://chetgardiner.com/MidiPortSetup.jpg
Output to Windows MIDI which is what I suspect is playing the .mid file in Windows Media Player…

Somehow the connection is NOT being made within Cubase between Cubase and the Windows Midi (Microsoft GS Wavetable Synth)? Where could that be?

Thanks again for your help…


HP Desktop, i7=4770 3.4 GHz 8 core processor - 16Gb memory - Windows 7 Pro - 64 bit.

Please post all of your system specs…

A question…

  • Have you ever heard any audio or midi sounds from Cubase through the speakers you are talking about?

I ask because Cubase needs an ASIO compliant audio card (installed internal to your PC) or an audio interface (which would be external hardware) for it to work. The audio card or interface would be connected to Cubase using an ASIO driver. If you don’t have the above noted ASIO driver installed then search to download the free “ASIO4All” driver and install that. Maybe your sound card will work with it but I doubt it.

I do see that you have a generic low latency ASIO driver listed under the VST audio system. Please show a screen shot of that too.

Also, please confirm that your project has a “Stereo Out” track. It should be at the bottom.

If everything that I ask above is OK then here is how you assign the Halion instrument…

  • The midi file is loaded onto a midi or instrument track. I use instrument tracks as they offer a bit more flexibility.
  • Highlight the track with the midi file and go to the inspector. Press the track number at the upper left to bring down the I/O routing menu.
  • Choose “all midi inputs” from the input dropdown.
  • Choose “Halion Sonic” from the instrument dropdown.
  • Click on the “edit Instrument” button to open Halion.
  • Choose one instrument such as the GM129 Stereo GM Kit.
  • Click on the “Activate effect” button in Halion. It will turn blue
  • Close Halion.
  • Make sure the track record enable button and the monitor button are deactivated.

You should be hearing your drums if everything was set up properly under the VST connections menu I mentioned above. It will be sent to the assigned ASIO audio interface set up in the VST connection menu through the default “Stereo Out” track that Cubase (hopefully) made for you when you created the project.

Of course do not have these tracks muted, record enabled or monitored. Make sure to have the Cubase volume (gain) turned up enough to hear it. Also do forget to turn up the volume control for your speakers too.

So that’s it… if that doesn’t help then we will have to start from scratch with how you imported the midi file and so forth.

My real guess is that you don’t have the audio hardware (interface) at all or it not set up correctly in the Cubase VST connections menu. If you don’t have the interface then you will have to purchase one to use Cubase.

There are many fairly inexpensive ones available. Especially to start with.

Examples from PreSonus that cost around $100. There are many other manufactures too:
http://www.musiciansfriend.com/search?typeAheadSuggestion=true&sB=r&Ntt=presonus+audiobox+usb

Good luck.

Regards :sunglasses:

Your last post triggered me to try something different.

I began with an all audio track project that I’d edited a few months ago on this computer. Upon loading it up, It played fine…

THEN I imported the midi file I’m trying to edit INTO a copy of THAT project and – lo and behold – it plays…NO fiddling, no finagling, no fuss, no muss…even assigned the instruments in Halion “correctly”, etc.

So there’s SOME setting (or combination of settings) cleverly hidden by the Cubase engineers (could they BE more obtuse?) that I’m not finding in the OTHER project I created from scratch.

The original process I went through was to choose one of the basic templates – Acoustic Guitar and Vocals – import the MIDI and delete the guitar and vocal instrument tracks and that’s the version that STILL won’t make a sound…

Ok, I found the VST Connections window (it was hidden way to the right of the visible panel - the curse of 2 monitors), I set the outputs in the “From Scratch Version” to stereo left and right and it STILL WON’T PLAY in the “from scratch” version. Maybe I have to close and reopen/reactivate it…who knows

BUT – who cares!

I can hear playback in the “start with a working project” version so I CAN do the editing of the MIDI drum track that I need to do.

I only entered MIDI-world to grab a drum track from a downloaded song to export into my Beat Buddy pedal – I NEVER record midi…always analog audio…

Thanks for your help… Even though I still have NO IDEA why the “from scratch” version won’t play, your suggestions DID trigger a work around for me… :slight_smile:


PS: This desktop is my day-to-day stuff and Video editing computer. In my studio, I have an HP laptop that is connected to 2 Roland Octa-Capture units… I mix in analog – Allen & Heath board, outboard efx such as SPX-90, Quadraverb, DSP128, Alesis compression, MicroVerb, etc. then back into a digital recorder or 2 mix tracks in Cubase. Since emerging from the audio learning curve a few years back I have no problems with Cubase in the analog realm. :slight_smile:

PPS: AH! Found it! When I loaded the “From Scratch” project and set the Stereo Output channels to my sound card in the VST Connections panel, the Halion instrument assignments weren’t there any more because I forgot to save them. So, I assigned instruments and VOILA! It plays… Sometimes “flexibility” means way too many moving parts… :smiley:

Glad it is sorted out.

Regards. :sunglasses: