Elements hangs after rendering (perhaps not render-related at all)

Weird and annoying: yesterday I spent the day in the studio with WLPro finalising an album for a client, and shipped out the 2444 files. Today it transpired that he also needs 16-bit files. I am not in the studio atm, but I do have my laptop with WL Elements, so a simple dither and render to 16 should just take a minute or two. Not so. After one render, WLe crashes. Again and again. Also, the .gpk is locked, so no waveform can be displayed upon restart. Trashing the prefs didn’t help. Any ideas about what’s going on? This never happens with WLPro…

Cheers,
j,

Update: I found the cause (?). If Preferences -> Global -> Audio -> Plug-in processing is set to 64-bit, while the temp file format is 32, WL crashes. If both are the same, either 64 or 32, all is good.

Edit: I spoke too soon. It HAS to be 32f. 64f makes it hang after a render.

j,

I can’t reproduce a crash or hang with Elements on Windows 10 no matter what those settings are. Since you can’t render all tracks at once in Elements are you rendering regions/tracks one at a time, or are you rendering whole montage? I tried both. And the only plugin is Internal Dither?

One track at a time, from the track (not montage) view. I’m not using the internal dither, in this case it was ToneBoosters as a master section insert. As a test I swapped it out for DMG’s Compassion, with the same result. The TB is VST2, Compassion is VST3, just to rule out that :slight_smile:

Honestly, it’s very strange, and quite unexpected. I’m NOT getting this in the studio, but there I’m still on .40. Perhaps that is a factor.

I have a couple of non-studio days coming up, so I’ll keep digging.

Edit: first try resulted in a hard crash. Settings: 64f on both processing and file, 2444 file with the dither as an insert, set to 16-bit, render as a named file, to wav16. The render went ok, but with a crash to desktop when trying to open a second file. Error: WaveLabElements9_5.exe caused ACCESS_VIOLATION in module “C:\Program Files\Steinberg\WaveLab Elements 9.5\WaveLabElements9_5.exe” at 0033:0000000040B1CC57 The crash log is saved.

More testing underway.

j,

Update 2: A couple of renders went ok, and then it crashed again: WaveLabElements9_5.exe caused ACCESS_VIOLATION in module “C:\Program Files\Steinberg\WaveLab Elements 9.5\Qt5Widgets.dll” at 0033:000000001C560090, QWidget::isVisible()

j,

Update 3: Well, this is interesting, it seems like it’s not render-related at all! Simply right-clicking to the right of the tabs, choosing “Open” and then opening a file makes it go poof. It may work one or two times, but it will crash eventually. Is the right-click-open function broken in .50?

j,

fwiw, it’s not a problem here, tried multiple repetitions. But at least you have crash logs.

Cheers. And yes, I have six or seven crash logs, if PG wants them :slight_smile:

j,