eLicenser catastrophe

I’m having massive problems with the eLicenser (using Mac Mini with Big Sur). Dorico hangs on launch, or starts, then freezes later. This is usually accompanied by an error message that refuses to go away. The error message is not always the same: here’s one I’ve had often (complete with spelling mistake :slightly_smiling_face:)

eLicenser Control - Error
Application ‘Media Service’ has caused the following error:
An unknown interapplication communication error occured. In case the problem persists, please close all applications and restart your computer.

  • Click to abort.

Clicking on OK does nothing. The application named in the message is not to be found in Activity Monitor. The message stays there, and I just sigh and restart the computer.

I contacted Steinberg support, who suggested the the dongle (a Steinberg USB key I bought last year) could be defective. I got a new one and transferred the license, but the problem is still there.

At present I cannot use Dorico: it may work for a while, but there’s no knowing when this problem will appear. Steinberg support doesn’t seem able to find a solution: in any case, they’re not in a hurry. Does anybody have a clue what is going on?

You’ve probably tried everything but just in case there’s a thread in the Cubase Forum that might help.

Steinberg USB eLicenser not recognized in Big Sur Mac

Some more information here as well.

Elicenser Does not read mi serials numbers in El Capitan

Have you ever opened the elicenser software and clicked the refresh/repair option? I have issues about 2x a year, and whenever I have the elicenser refresh itself it’s immediately sorted.

Thanks, David and Romanos, for replying so much faster than Steinberg support.

I looked at the linked discussions, but sadly they don’t help in my case. It can’t be an issue with a USB hub: the eLicenser is plugged directly into one of the USB ports of the Mac Mini. I’ve tried every option I could find in the eLicenser Control Center: recover, clean up memory, update database and Maintenance.

My problem is, what do I do now? I’m convinced that Dorico is the best notation software available, but if the malfunctioning licensing system prevents me from using it, and Steinberg support doesn’t offer a solution, I will have to give up Dorico and ask for it to be refunded. I don’t want to do that, but if this situation continues I don’t see another option.

1 Like

I’m sorry to hear you’re having such issues!

Next comes the age old question: have you run maintenance tasks and then restarted your machine?

I have also had to unplug and replug in my dongle before because for some reason it just didn’t register as being plugged into the machine. Sometimes that alone is enough to take care of it. I’ve noticed that once in a blue moon, when my Mac goes to sleep, after it wakes back up something happens to some of the ports and the things that are plugged into them are no longer registered until you unplug and replug them in.

Michael, I too am sorry to hear that you are having difficulties with eLicenser. It may be cold comfort for you to hear this, but we announced only yesterday that the next version of Dorico, arriving early in 2022, will not use the eLicenser system, and will instead make use of our new Steinberg Licensing system, which has no reliance at all on the USB-eLicenser.

What I would propose in the short term is that I send you an activation code that you can use to activate Dorico using the Soft-eLicenser on your Mac, i.e. that you unplug your USB-eLicenser and put it in a drawer until you need it to upgrade to Dorico 4, which hopefully you will feel inclined to do upon its release.

I’ll send you a new code, which you should enter into eLicenser Control Center after ensuring you have disconnected your USB-eLicenser from your computer, so that the license isn’t deposited onto your dongle.


I’ve run maintenance, restarted, unplugged and replugged the dongle more times than I can remember!


How lovely to get such a speedy and helpful response!


One last ditch effort might be to reinstall the licensor control center app. Who knows… Maybe some file path was broken for some weird reason and so the program can’t function properly.

Yeah, did that too! In any case, thanks to Daniel I’ve now got a trial license that seems to be working fine without using the USB eLicenser.


For what it’s worth, I had a similar issue, and tried a lot of stuff. What worked in the end was using a different USB port. I have no idea why.

Yes, I tried all the ports I could find: direct on the Mac Mini, through different hubs…

In any case, I’m not counting on going through all that again. I have a working solution until the 9th of February. Afterwards, we’ll see: hopefully Dorico 4 with the new licensing system will be available by then.


Steinberg just sent me a new activation code for the Soft eLicenser. Now my Dorico license is back on the computer and not time-limited: I can put away the dongles for good.