eLicenser Control software latest version problem

Hi All,
Even though I have the latest software version(6.10.5.1204) of the eLicenser, I get the error message as in the attachment.
My operating system version is MacOS 10.12.2 Sierra. I had a try also with privileged access(as a root user), but still get the same error.
Are there any solution for such a case?
Thanks in advance,
Bora
Screenshot 2017-01-20 14.37.55.jpg

Hello,

It seems that you’re attempting to activate your download access code, not your activation code. You will first need to redeem your download access code through your MySteinberg account. Once this is done, you will receive a new activation code (starting with 0240) that can then be activated in the eLicenser Control Center.

Additionally, I’m not seeing a soft eLicenser. Please do the following to create one:

Close all programs.

Download this file:

http://support.steinberg.de/elc/mac/elc-installation-helper.dmg

Double-click on the downloaded file to start the reinstallation of the eLicenser Control Center.

Thank you.

Hi Alex,
Thanks for your quick response. Everything is fine now. As a feedback, directions in the web page a little bit misleading.
Have a nice day,
Bora

Glad you’re up and running Bora