eLicenser does not work properly

Hi folks, I have the latest version of eLicenser software installed but it’s not working properly. I tried it with two PC running Windows 10 and a mac. As you see in the photos menus are hidden and I can’t see what’s written. The latest Framework is also installed. There are no changes if the USB eLicencer is plugged or not. So any ideas?


Sorry there are no screenshot attached.

Does your screen resolution meet the system requirements? Do you use any zoom factor in Windows system?

Martin.Jirsak, changing screen resolution settings didn’t change anything, I’ll try to attach again, sorry about that.


Can I see it right you are on Windows 7? Make sure you have the very latest SP and very latest update installed, please. Make sure the right Microsoft redistributable is installed. And try to update your graphics card driver, please.

I’m on windows 10 on both pc’s, I also think the problem is about my graphic cards. Later I tried on my mac again and it worked just like the way it should. By the way it can seem like windows 7 because I shooted the photos from my bootcamped pc