eLicenser fails most of the time when trying to open cubase, and my vsts are "black listed"

I tried to contact support, but that doesn’t work - when I hit “send” for the email, I get a link to the support page which is back to square one.

I can’t reliably use the elements trial -most of the time when I open the application, a pop-up says the soft elicenser check has failed, then it closes out. I don’t understand what the issue is. The only time I’ve gotten it to work, there are LOTS of pop ups and errors, and a very slow load up, and constantly pop ups saying “timed out” with the name of one of my VSTs at the top.
Then at the end I get one saying “some content could not be loaded. Either licenses are missing, or licenses have expired…” yada yada yada. Why must it be so hard to trial this software?

Once I finally created a project, NONE of my vsts work, it says they’re blacklisted. What?

I’ve heard good things about this software which is why I wanted to try it, but it’s so buggy I don’t even feel like touching it again.

Hi and welcome,

Are you sure your mail to the support has not been sent? Isn’t it just forwarding back to the support page after sending the mail? Of course, I would expect an confirmation…

Regarding to your license, make sure the very latest version of eLCC is installed properly. Make sure the Soft-eLicenser Number has been created. And make sure the Usage Period of the Trial version has started.

I’m sorry to say, but it already happened in the past… Make sure you have no old Cubase cracked version installed or it wasn’t installed on the system in the past (the eLicenser application would be corrupted then).