Elicenser is absolutely horrible - I am about to leave Dorico

This - or some sick version of this - happens EVERY MORNING:

Launch Dorico (right after launching system)

Failed to send GetInfo command - Click OK

Dorico Pro 3 Splash Screen

Nothing happens for 5 minutes - I do a force quit

Launch Dorico

Elicenser Error: There is a usb communication problem. Please connect the Elicenser to another port - OK

No license was found Click activation code.

I enter the code I got from Steinberg.

License activation failed

WTF!!!

Application has caused the following error: ??? - OK

EXIT

Launch Dorico

Failed to send GetInfo command - Click OK

Failed to send GetInfo command - Click OK

Application Dorico Lite has caused the following error Failed to send GetInfo command - Click OK

This time I get the Dorico file selector and choose my (large) project.

I check the splash screen: Its Dorico Pro 3

“This project contain more players than this version allows.” - Open.

My project opens, but I am not allowed to work in it.

I check the splash screen: And get the ELicenser Control Error:

Failed to send GetInfo command - Click OK

The splash screen comes up: Dorico Pro3

But I still am not allowed to work…

I quit (the programm …. )

This goes on EVERY MORNING!!!

After a couple of iterations sometimes 5-6 taking an hour!! — it works.

I am using the latest Elicenser, latest Dorico, have used EVERY USB port on my system. Using a brand new MPB 16`with 64gb on Catalina.

And I CANNOT WORK!

That sounds like you actually have Dorico Elements (or even LE) running. It’s the same software, just with a different licence.

You’ve certainly been unlucky with your experience: the licensing system works fine for most, but does cause mild irritation occasionally for some.

The Dorico team have stated that Steinberg is reviewing a new system to replace the current model, but when that will happen is unknown.

I’m sure one of the team will be able to help you out. Dorico is worth it.

I don’t have any advice except to say sorry, that stinks. I understand the frustration of being stymied in your work (hasn’t happened for me with licensing, but I’ve had plenty of hardware issues unrelated to Dorico). We’re all looking forward to a new licensing system, and hopefully it’s imminent. Meanwhile, hopefully the team can get you sorted out.

If I have Dorico LE running, where ( or how) can I get rid of it?
I bought - and use - the Pro3 version.
Plus the Programm seems to be so confused, that it displays the Pro3 splash screen but runs the LE version?
WHY on earth do I have to go through all this and then for no apparent reason it suddenly works?

LE, Elements, and Pro are all the same program, just different license restrictions. You have only one “Dorico” installed. The licensing software is the thing that controls which version is used.

I don’t know why it’s opening as LE, if it is. Are you possibly holding down Alt or Cmd when it’s opening? That’ll cause it to open as LE or Elements.

How old is the physical eLicenser? Is it one of the short stubby ones or one of the older, longer ones?
What sort of USB/Thunderbolt adaptor is it plugged into? Have you tried more than one?
If you open the eLicenser Control Center, what version number is shown in the title bar? Have you run the eLicenser Control Center’s maintenance tasks, with Dorico closed?

For what it’s worth, I’ve been running a 16" Macbook Pro for a few weeks, opening Dorico at least daily, and I’ve had zero trouble from the physical eLicenser. I realise that’s not much consolation to you, but the fact remains that it’s possible for a physical eLicenser to work ok with Catalina and a brand new MBP.

Jochen 11, please check your private messages.

Bought the usb thing together with Dorico in December. Yes, short one.
Used many different USB adapters from Apple and … others.
ELicenser version number is 6,11,10,2262
Yes to “maintenance” - don’t want to close Dorico right now as it is running…
Besides the Steinberg / Dorico usb, I have a vsl-usb dongle as well who is giving me some grief too:
Same sht: Some error messages, then for the rest of the day a running system.
I have a very solid system running large sessions on Logic, nothing else is behaving that way.

You’re not alone in hating the useless e-licensor. I usually get the - “Failed to send GetInfo command” - at least once a day - but it eventually opens and runs the app. I also had the “This project contain more players than this version allows.” - a couple of times (I use Elements but had not reached the maximum allowed players)

I did have a terrible error the other day when it suddenly wouldn’t save my work, error message was that “this product is not registered” - lost about 30 mins of work, prompting me to be even more diligent about incremental saves…

Please Steinberg get rid of this terrible system - it’s bad enough that I have to carry a dongle around with me for traveling, so easy to misplace or get stolen. Machine based authorisation that can be transported such as the Waves system is my favourite.

For the record, I’m not about to easily jump ship on Dorico, but this is becoming very frustrating. After using Dorico for more than a year (starting with v2) I am now experiencing this exact problem too. I’ve just today updated the eLicenser software with the newest version, ran maintenance (multiple times), changed USB ports for the key. When I run Dorico, it gives me the “failed to send GetInfo” error message for both Pro and LE, then starts in Elements mode (I have a Pro 3 license). It works fine in Elements mode, but I need Pro. It’s now done this to me about 5-6 times in a row, even after a reboot.

The Steinberg support page says Dorico 3 is compatible with Catalina with the newest version of eLicenser software. I’m not sure what else to do. I rely on Dorico every week so this is pretty urgent for me.

Dorico Pro 3.0.10
Mac OS Catalina 10.15.2
Mac mini (Late 2012) upgraded with 16GB RAM, 250GB SSD

Just an update that after I moved on to other tasks and then came back to it, it started properly in Pro mode without issue. Maybe it just needed a break. :slight_smile:

Regardless, I need to be confident it’ll start properly each time, so I’m not saying the issue doesn’t need to be addressed any longer. I too would advocate for a more reliable system, whatever that might be.

Clearly there is some software glitch occurring. The behavior described above is definitely not normal. I haven’t upgraded to Catalina yet, but I never have problems (save forgetting my dongle at work or home… but that’s another issue entirely). :angry:

Ok, maybe it is solved.
Frank Heckel gave me the idea and I tried it out today.
I also have had occasional trouble with Elicenser and my vsl-usb dongle that resolved by itself over some time (about an hour or so each time).
So today I transfered all my vsl-licenses per Elicenser to the new Steinberg/Dorico key.
Pulled the vsl Dongle - there is now only one USB key talking to Elicenser - and started Dorico:

No problem.

So what was it?
The vsl-key is very old? (I use vsl from their very beginnings, as soon as they started the usb thingy, I got three of them for satellite systems)
There were a lot of licenses on the vsl-key?
Elicenser cannot handle more than one usb device?

I don’t know.

But many thanks to Frank for his idea!

Certainly the old, longer USB-eLicensers don’t work well on modern systems, and you should use the newer, shorter (c. 3.5cm in length, rather than c. 5cm in length) ones. I’m glad this has got you back up and running. I hope it stays that way.

There should be a warning at Elicenser or vsl that their software licenses on an older usb keys can cause trouble with completely different software on newer keys.
This has lost me many hours.

Hello Daniel,

when you say 3,5 cm and 5 cm, do you mean including the USB plug? My elicencer is circa 3,8 cm long without plug and 5 cm with plug, so my question.

Thank you.

The one on the left is old; the one on the right is new.

Thank you, pianoleo. I have the old one, then.

I’ve been using mine since Cubase 4, so it’s the older one. How do we get a new key and transfer our licences? I’m hopeful that we don’t have to actually buy a new key.

You do have to buy a new key, I’m afraid. You can purchase a new one either from the Steinberg online shop, or from your favourite music shop. Once you receive your new USB-eLIcenser, you plug both your old one and your new one in to your computer at the same time, and simply drag all the licenses from the old eLicenser to the new, empty one.