eLicenser Issues.

Hi.
So in the past 3 years- every once in a while i get these messages when trying to run cubase.
The dongle is the old longer one.
I tried updating the eLicencer, tried reinstalling cubase(happened on the last 3 versions), formatting the whole computer (like three times over the past 3 years).
Only thing that seems to work is taking out and reinserting the dongle which is quite frustrating since i have an imac pro and i have to reach all the way in the back.
To me it seems like the dongle (which i had since cubase 4) has degraded and not 100% anymore, does steinberg have a replacement program?
Can i use my ilok instead?
Screen Shot 2020-01-28 at 10.54.36.jpg


Hey, I just went through a dongle problem myself. I was using the same one that came with SX in 2003 or something. Anyway, I was getting several errors on start up, no license errors, media service, Cubase Artist errors (I’ve never owned Artist) etc… I went to our local music store and purchased a new steinberg dongle for $38. Put the new one in and transfer the licence over, remove old one. All of my errors went away, and Cubase launches without a hitch now.

I’ll add this, don’t go the Lost/Damaged Dongle - New Access License route, that no down time thing. If you can see your license in the eLicense program, that’s all you need to transfer that license to a new dongle. Look up transfer license, it’s super easy drag and drop.

Hi there and thanks for the replay.
I guessed that purchasing a new dongle might fix the issue but thought steinberg might address this issue and perhaps replace the faulty usb with a new one like Ilok does.
What can i say i’m a dreamer…

Haha, ya I wasn’t going to wait for that pig to fly.