eLicenser Maintenance not working (screenshot)

failed to send elicenser information.
Also, Cubase won’t start up, and I’m guessing because of this.


And incidentally, with this same USB licenser plugged into a different computer, a MAC, the maintenance succeeds fine. It’s the elicenser on the PC that doesn’t work. And I’ve tried reverting back to an older version of the eLicenser software.

Have you tried running as administrator? I think that will work.

Thanks. I just tried, and it got stuck again trying to send the elicenser information… the last step, step #6. And then it just ends up saying “Failed” per the screenshot below… I also get those 2 errors I posted above about “Application LCC2 has caused the following error” and “an error occurred while accessing the elicenser”… right before I get this final screenshot:

only thing you can do now is contact steinberg. this 100% looks like something that messed up on their end, but they will make you pay for a new elicenser. its gonna come down to this BS, even if its their fault, you pay for it. looks like this is where it will be going, i ahd a simialar experience. waste of time. no wonder they are removing elicesner trash.

1 Like

Interesting that I’ve never ever had any problems with the elicenser not working… UNTIL now, years later, right when they are working on their licensing system.

And again, the elicenser maintenance works fine on my MAC. So I can use Cubase on my MAC. But here is where I get stuck on the PC side, when starting up Cubase… It gets stuck on “initializing eLC…”

Uninstall ELC
Reboot machine
Install latest version (make sure it is latest)
Run once (only once) as admin

Please see if this helps. Follow above steps exactly.

1 Like

Thanks Phil. When you say “run once”, you mean the e licenser software? And should I run the maintenance thing inside there?

After installation and reboot. Start the ELC Software as Admin but only needs to be done once. Following starts will not require starting as admin. (And even this once is just a precaution tbh).

You can then try running maintenance on this first run or close it after that and try again.

Also may be worth just quickly trying the dongle in another USB port although that side of things appears to be fine, as you can see the licenses.

And a final thing to point out that this problem, failed to send information does happen sometimes if server is slow or under maintenance. So may be worth just waiting a day before you escalate to support.

1 Like

OK, thank you. I’ll give it a shot. Seems not to be the licensing server as it works fine on my MAC… though that could have been a timing thing too.

So, I’ll run it as adminstrator, but I won’t set it to run that way all the time.

I’ll report back. Thanks again.

Yes I noticed you had success on the MAC but as you say this could just be timing.

Yup that’s it.

1 Like

OK, followed your directions to a T. Same errors, and for some reason after running the maintenance thing, the very last step says it can’t connect to the elicenser, and the elicenser software shows no USB device or any licenses. Screenshots:

Hi @shagazulu ,

Is your eLicencer dongle in a USB hub? That has caused me to have similar-sounding problems in the past.

If so, try to connect it into a direct USB port if possible.


Thx Alexis. I’ll try that.

That seems to have fixed the problem. Thank you to all. Thanks Alexis.

So odd. I’ve never had problems with the elicenser before. Now I’m thankful they are moving away from it.

You’re very welcome :slight_smile:

A powered hub might be something to consider as well. I’ve not had to do that, but the Steinberg tech guy I spoke with suggested that as well.

1 Like

I did mention this in my first post.

1 Like

Yes, thank you.
I’m thankful this didn’t turn into a multi day troubleshooting affair. Thanks again.

1 Like