eLicenser Not Allowing 8.5 to Open


I am running into an odd problem that only appears to be close to a couple others, but the solutions I have seen so far go beyond the solutions that have worked for others.

Each time I try and start Cubase, I get the following message:

Application ‘Cubase / Cubase Artist’ has caused the following error:
An important service has become unresponsive.
Please restart your computer to fix this problem.
Please visit <www.eLicenser.net> to download and install the latest version of the eLicenser Control software in case the problem persists.

I have restarted. I have run maintenance of the control software. I have re downloaded the most recent controller. I uninstalled the whole thing and then tried to install it again. Keep getting the same message!

This has been going on about a week. I run Windows 10 but had run Cubase 8.5 successful under this OS. Help would be greatly appreciated!

Have you set the eLicenser software to “run as administrator” then run the maintenance routine?

Regards. :sunglasses:

Is it possible that you’re experiencing an issue related to running software as “normal” user vs. running “as administrator”?

Please see this post for details.