eLicenser not detecting usb licence on OSX Monterey

Hi, for some reason I am not able to start up Cubase Pro 11 on my MacBook… I have my licenser connected on the dongle. I have tried to reinstall version 11.0.4 but still it doesn’t work. I am running OS Monterey 12.2.1.

I tried running e-licenser but it doesn’t read it the licences. I have updated the eLicenser control centre to version 6.12.8.3306. It just keeps saying ‘reading eLicensers’. Also if I click on any of the menu items eg. Registration or enter activation code, the revolving rainbow ball appears and the control centre becomes unresponsive. Has anyone have a solution please as I have a gig soon and I need Cubase to run for live recording.

I would appreciate any help

Further info:
By the way, I contacted Steinberg support and so far no reply.
Also, I know the USB dongle does work on my Windows desktop, so I think its not the dongle problem.

Hi,

Could you try other USB port, please? How old is your USB-eLicenser, please?

Thanks for the reply,
I have already tried different ports on my MacBook but it still doesn’t work.
I know the usb licenser works because it works on my windows desktop. I still think that it may be incompatibility of the eLicenser Control Centre on OSX Monterey.

Ok, I think I have solved it for the time being. I uninstalled the latest version of e licenser control panel and installed the previous version, 6.11.10.2262 and that is working at the moment. Let’s hope steinberg sort out the latest version….

1 Like