Elicenser not recognizing dongle

Due to a move, I haven’t used Cubase 8.5 (64 bit) for a couple of months. Re-setup the studio and now I get “no valid license found” when I boot up Cubase. I’ve installed the latest E Licenser program (uninstalled and reinstalled a number of times) and have the latest version of windows 10 in 64bit. I even reinstalled Cubase 8.5 with no success.

I did notice when I installed/repaired Cubase or E Licenser, my dongle lit up for roughly 10-12 seconds and then just quit. The LED doesn’t stay continuously red as it did in the past. I have the original dongle when Cubase switched from a parallel port dongle to USB…maybe the reason why?

I tried the dongle in all my usb 2.0 ports and it didn’t help either.

I did check the Protect Executor device in Windows 10 (one time it showed up as a Steinberg device) and the trouble shooter notified me that no drivers were installed. I did a reinstall of Cubase and E Licenser with no success.

Before I go through a zero downtime request and issuing a support ticket…is there anything I can do to get Cubase up and running? Appreciate any help beforehand as I’ve read that getting and installing licenses via a new dongle is a hassle

many thanks

Check on another computer or Uninstall eleicencer and try the version included with 8.5.

The other computer recognized the dongle. I uninstalled the E-licenser and reinstalled the E Licenser that came with the Cubase pro 8.5 upgrade.

Windows 10 see the dongle and says it requires further installation. The driver isn’t installed. E Licenser fails to show it. I also reinstalled Cubase3 8.5 and that didn’t help either. I’ve run out of options. Anything else I can try?


Google elicence dongle install windows 10


Can you please PM your USB E-Licenser number?


how do I PM?


Press the PM button on the right under my name, Post, Joined, etc.

What are the specs of the other computer where the key worked?

Cubase computer:

HP I7-2600 3.4Ghz 16 G Ram (2nd generation)
windows 10 64 bit

my laptop that showed ID Protect Executor

Lenovo Yoga 2 Pro
I7 4th generation
Windows 10

ID Protect (assume it’s the dongle) shows up in both computers…and it says that drivers are not installed. Requires further installation.


did a full e licenser install on the laptop above and all my licenses showed up. It’s not the dongle.

The only difference may be that I installed windows 10 64 bit anniversary edition on the Cubase computer. Can’t remember if I installed windows 10 anniversary edition on the laptop just yet.

sent you a PM

Sent you an email. Please reply to that email for further assistance.