elicenser not working with Windows 10 TP

Wasn’t completely sure which forum this should go in, but this seemed the most likely…
I’ve been running the Windows 10 Technical Preview and discovering which audio/video software works.
cubase 7.5/8 install fine, however the eLicenser software seems to have trouble updating itself (the ‘maintenance’ thing) so doesn’t confirm my licenses and so doesn’t work.

  1. Has anyone else tried this?
  2. Is it yet supposed to work?
  3. Is it likely to soon? as the release date for Windows 10 isn’t now that far away… (29th July).

Oddly enough my iLok2 works fine, so I can use my plugins, just not the host…


Working 100% correctly here now on build 10130. Manually update Elicenser if you didn’t do that.

right. Was on the build before that, so I’ll give it another go :slight_smile:

I’m having problems with eLicenser and the release version of Windows 10 Pro. I tried running maintenance and it freezed at about 20% in step 1. Any idea why? Otherwise the licenses seem to work, as Wavelab and Cubase do not throw error messages.

Seems to have fixed it. My solution was changing usb ports on my ASUS P9X79. There are currently no dedicated usb drivers on the asus support pages for windows 10.