eLicenser problem with Cubase 7 update?!

Hello kids!

I’ve purchased my C7 upgrade… I’ve run the installer and installed the upgrade. However, I’m having trouble with the eLicenser… I click on “Enter Activation Code” and then input my key, but then during the “Do not disconnect your eLicenser…” progress indicator, the program comes up with “eLicenser Control Center has stopped working, close program” dialogue.

What am i hitting here to cause this to crash?

Did you install the latest eLicenser software?

Sir yes sir! latest version on the site -

Just tried disabling my Antivirus and Firewall - same result.

I then looked at the error info and here it is copy pasted:

Stopped working

Problem signature:
Problem Event Name: APPCRASH
Application Name: eLCC.exe
Application Version:
Application Timestamp: 50a0ea9a
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.17725
Fault Module Timestamp: 4ec49b8f
Exception Code: c0000005
Exception Offset: 000332bd
OS Version: 6.1.7601.
Locale ID: 1033

Hi all,

I have the same problem too. eLicenser crashes during license upgrade with the same error message.



Workaround found.

Install eLicenser on another computer and upgrade the license. This works.

Regards Ralf

Yeah i’ll give that a try.

But man, that’s lame - it should work on all computers. (sigh) i hate dongles. :angry:

Yup that worked.

Once again. That’s uber lame.

Have you tried this tip in the knowledge base? It worked for me.

Yeah I just tried that… it did work!! Had the same issue when I tried to install the trial version of Dark Planet. Not only did i NOT get a trial activation code along with the download (and had to contact Steinberg Tech Support via email) but the damn license wouldn’t download to my dongle.

Man. I can’t stand dongles. I understand the need for them, but man… what a pain in the @$$. :imp: