eLicenser shows deactivated SofteLicense - Installing Nuendo Trial Issue


I just installed Nuendo 10.3 trial version which promises to provide a 60 days free trial. I downloaded it using the Steinberg Download Assistant.

After installation when I open the eLicenser control, it shows me several errors before finally showing a deactivated SofteLicenser in the Control window. The errors are about repairing the current eLicense, maintenance issues, etc. (see the screenshots). I have tried installing/uninstalling the recent version of eLicenserControl from the website. I have also tried the eLicenser version that came with Nuendo 10 trial, but I am seeing this same deactivated license. I am attaching some screenshots for a better understanding of my problem. Please help.

Thanks in advance.

You do need an usb dongle for the nuendo demo. This has of course nothing to do with the errors. For the rest I am not an elicencer expert. There is a program from Steinberg called elicencer helper that will create a new soft elicencer, but only use that if you have no licences on it now.