eLicensers Missing from MySteinberg - Can't Reactiviate


I work for a schools and we have 17 licenses for Cubase Elements 9.5.

I’ve recently rebuilt all the computers and they need to be licensed. Unfortunately all the elicensers have disappeared from MySteinberg so I can’t reactivate the new eLicensers.

I have the original 17 DACs but they are no use since they have already been used.

What can I do now? I have logged a support ticket but no one has replied for 3 days and I have students and teachers waiting to use the software.

Check out “Reactivation” on the Steinberg Support website.

I’ve done that, there are no elicensers listed in MySteinberg to “reactivate”. And I can’t use the old software activation codes as they have been used and won’t work.

I don’t even have elements 9.5 listed in myu software list now, just the older cubase softwares.

I would double-check that you’re using the right account.

Hi Steve, I’m definitely using the right account.

I did have one elicenser activated, I clicked to reactivate it and I got a page that said Oops Something Went Wrong. When I checked again the elicenser was missing and when I tried to re-add it it said that it was depracated.

Basically I need new DACs or Activation Codes so I can put them into the elicensers on the computer to register them on the website then I can make sure they are never messed with again (I have inherited this role and not come across this software before)

If the case is that your 17 registered soft-elicensers are missing from the account, I’m afraid only Steinberg support can help.

I think I’ve sorted it.

I found the original emails that contain the Activation codes (from 2018) I’ve managed to register 16 of them in Mysteinberg, just one isn’t working. That will have to do for now. So the old eLicensers are now registered so now I can reactivate them to the new eLicensers that are installed on the computers.

I hope that Steinberg can save the last license but I’m not holding my breath.

If you used the original activation codes from 2018 and they worked, they must have never been activated or registered before.

It says they were activated in 2018
Screenshot 2022-12-02 163244

Only one code would not work, said the elicenser was depracated.