Empty measure at end?

I can’t seem to get rid of an empty measure at the end of my flow. It is created every time I input notes in the previous measure. How can I delete, with no strings attached, an empty measure at the end of a piece? I’m thinking of something akin to the Sibelius command+click. Thanks!

Try the “Trim Flow” command in the Edit menu of Write mode.

If extra bars are being added to the end of your flow when you add notes, perhaps you are in Insert mode.

Thanks for that, Ian. I had the same problem. The Trim Flow command is in the Write menu, not the Edit menu, though. :slight_smile:

Oops, thanks!

I’m in the write mode, I have an empty bar at the end of the flow. I clicked on Trim Flow from the Write menu but nothing happens, the empty bar still remains.

I must be stupid (well actually, I already know that! Haha), do I have to select / do something else before selecting the Trim Flow command?

Thanks in advance.

I still have the same problem as discribed. Trim flow doesn’t work no matter where I put the caret.Please help!

Can you attach your project here, if you’re still having the same problem?

Hi–just got a chance to try it out. I thought I had done Trim Flow before, but this time it worked! Thanks very much, all. FYI, turning off insert mode still gave me the phantom measure.

I’m having this same problem. I’ve tried to use trim flow command, but to no avail. Here’s the project. Thanks for your assistance.
Christina’s Birds - Full score - Wise Ones.dorico (1.2 MB)

Select the last measure, Shift-B, -1, Enter.

If Trim Flow is not working, select the rest in the unwanted bar, press shift-B, type -1, then press Enter.

I think the reason that Trim Flow does not work in this instance is that there appears to be something in that bar. If you unhide signposts and delete those that appear there, you will find that Trim Flow now works as it should.