"Enable solo on selected tracks" preference

Hi,

I need to compare several audio track versions, and for that I need to solo them exclusively. Thanks to this forum, I learned a nice trick of pressing Ctrl/Cmd-click to achieve that.

However, there is also an option in PreferencesProject/MixerEnable solo on selected track, which theoretically should give the same exclusive-solo behavior without Cmd-click. When I check this option and save preferences, nothing changes neighther in the project window nor in the mixing console window. So, it seems to be like a bug.

I use Cubase 12 Pro 12.0.70 build 464 (Apple Silicone).

Confirmed (Cubase pro 12.0.70 / Windows 10 22H2), after having ticked the Preferences > Editing > Project & MixConsole > Enable Solo on Selected Track option.

And it’s not only a visual issue : it’s a functional one. Selecting a track and playing on it doesn’t prevent others tracks content to be heard, when playing back/recording.

Working correctly here. Can you provide steps to repro?

For this to work, a track has to be soloed first.

Repro:

Activate Enable Solo on Selected Track
Solo a track
Select different tracks
result: selected tracks are soloed.

1 Like

Then, I don’t get what the Enable Solo on Selected Trac k is for. Repro :

  1. Be sure to have already previous recordings on some track(s).
  2. Tick the Preferences > Editing > Project & MixConsole > Enable Solo on Selected Track.
  3. Select another track and play/record it. The track(s) in which already exiting recorded data is/are played, contrarily to what the involved preferences option suggest.

I don’t see in which way your repro is specific to the preferences option involved : this will work, no matter if the option is ticked or not…

I do not understand what you mean. Having data on the track, or not, is not a prerequisite.

The only prerequisite is that one track is soloed. Then, when selecting other tracks they are soloed, and deselected tracks are un-soloed.

2 Likes

Care to be more specific ? Because what you are stating is already what happens, even if the involved option is unticked.

In any case, I invite you to try my own repro and report back the result, this with or without the option involved…

EDIT : my 1) repro stage was to check that a track, no matter what it is, and containing eventual events/parts are played. So, indeed, it’ s not a prerequisite : it’s the just the sure way to check Cubase behavior regarding the option discussed.

In that case you did not have a soloed track to begin with.

To solo tracks upon selecting them when this is needed. The pref can be left activated all the time, and then simply soloing a track allows one to do what the OP is asking about.

1 Like

This isn’t clear for my two digits IQ, sorry. So, can you give me two clear repros , one without the “Enable solo…” option and another with it, in the following case :

  • track(s) have already audio/MIDI events/parts on it/them (this to be able to check if a ‘solo’ state is actual).
  • another track is selected and set for monitor/recording.
  • We start/record Cubase and stop it after a given time.

What is/are the result(s) and what are the eventual differences between the two ?

This is only about soloing tracks, not record-enabling or monitoring.
@cubic13

Cubic, like Steve is saying it doesn’t matter if you have any events on the tracks and it has nothing to do with recording.

You have to FIRST have a track soloed. Then you select different tracks and solo should switch to whatever track is selected.

I got that already, thanks…
My concern, as well as @Dmitriy_Kuznetsov one, I think, is what are actually the changes in Cubase behavior whether the “Enable solo…” option is ticked or not…

Did you try it???

Enabled - when you select different tracks solo will follow the selection.
Disabled - when you select different tracks solo will not follow the selection and will instead remain where it was…

2 Likes

@steve thank you for the provided steps! I can confirm that if I enable the setting Enable Solo on Selected Track when there are soloed track(s) or I solo a track, then switching selected track soloes this track exclusively (all other tracks become muted). My bad that I did not realize that I needed to initiate soloing myself after enabling this setting.

1 Like

Of course, i tried it, and what I see is the following :

  • “Enable Solo on Selected Track” ticked : Indeed, we have the need to have an already soloed track for it to work. Only after this prerequisite, the option will be fully applied. Why so ?
  • “Enable Solo on Selected Track” unticked :
    Cubase behavior is much more predictable, in this case. At the ernd, I’m still wsondering what the ‘Enable solo’ option is for…

Overall, I’ll keep this option unticked . Thanks for chiming in, @MattiasNYC:slightly_smiling_face:

Also, it is not possible to Solo multiple different tracks, such as MIDI or Instrument tracks simultaneously, unfortunately.

1 Like

No, this is not correct. See the video above.

@steve could you please share the link to the video as for me (in Firefox) it says “No video with supported format and MIME type found.”

Well just give it some thought. If you are just selecting a track, do you always want that track to solo? Probably not, right? Suppose you enable ‘track selection follows event selection’ - now if you click on an event just to move it, would you always want it to solo the track?.. because you also selected the track when you selected the event. If you don’t want that then all you have to do is to not have a track soloed before you make your track selection.

That’s why it makes sense.

No, it’s equally predictable. We know what happens in both cases. With the function enabled all you have to do is pay attention to if you already have a track soloed or not. That’s all.

Here you go, the raw link.

1 Like