Endless Authorization Loop with Steinberg Download Manager

I haven’t had time to use my studio this year. Now that I have time, I wanted to update my version of 10.5, but the download manager isn’t working. The goal was to see if I still liked it enough to move on to 11.

I was prompted to update the download manager, so I did. I was then asked to sign in with a pop up, and pressing the button sends me to the Steinberg site. I sign in at the Steinberg site, and it tells me that I have to let the browser open the download manager for it to work. Instead of the manager opening, I just get the Sign In button over and over.

I tried reinstalling the download manager, updating elicenser, and deleting all related cookies.

Any suggestions?

I had the same issue (as did several others). Re-syncing my PC clock solved the issue.

It would have been nice if the Download Assistant had given us a clue about what we had to do rather than going into a perpetual sign-in loop.

Weird! Thanks for the information. I’ll try that.