Endpoint config input limited

I have a multirack instrument in Kontakt for each family of instruments, all routed within Kontakt correctly, all to stereo outputs (two channels per instrument). The mixer in Dorico, however, only recognizes the first 6 of 8 instruments from any given instance of Kontakt…if I want the last two instruments to work in the mixer (as their own instruments), I have to change the Kontakt output to mono (to clarify, the outputs in the mixer are present, they just don’t have any signal running through them)I am thinking this is an issue with the endpoint configuration/setup, but there is no stereo/mono option anywhere.

Is this common? Does dorico explicitly only understand the first 6 stereo instruments of a particular endpoint config? Is there a way to change that?

I’m not sure what may be happening here. I suspect that the first time Dorico saw Kontakt, it had 6 stereo outs and it isn’t able to adapt if you have an instance of Kontakt in an Endpoint Configuration with a different number of outputs.

In that case, what would be the solution? A total reinstallation of Dorico, and then integrating Kontakt only after I set up the endpoint configs?

Reinstalling Dorico won’t make any difference. I think you have just run into a limitation where Dorico can’t cope with multiple instances of the same plugin with different number of outputs

That did it! Thank you!!!

What was the solution for this? I’m currently experiencing it now with 6 stereo outputs, with 1-5 working and the 6th showing up in Dorico as a mono output.

Which plug-in are you using, @kspierson?

@dspreadbury I’m using Kontakt (v6.4.1)

Are you using a single instance of Kontakt, or multiple instances each exposing a pair of outputs?

@dspreadbury Sorry for the delayed reply; I’m using multiple instances of Kontakt, each with a different number of outputs configured (i.e. an instance for horns with 6 stereo outputs, an instance for string sections with 5 stereo outputs, etc). Seems to align with the outputs available in the mixer until I get past 5 outputs/instance, after which the 6th+ output in Dorico is mono instead of stereo. I was hoping @zutzutriot could share what his solution was, considering his issue started at the 7th stereo output from a Kontakt instance.

I’ll ask Paul next week what the nature of the limitation in Dorico that he refers to might be, because I’m not familiar with where that problem might lie.

Thank you @dspreadbury!

@dspreadbury Any update on this?

Isn’t this just a mater of setting the number of audio outs in the Endpoint Setup?


No, I don’t think so: it’s some kind of internal bus limitation in the audio engine, if I understand correctly. I’m sorry that I don’t have an update for you – I confess that I neglected to discuss it with Paul. I’ve made a fresh note to do so on Monday.

1 Like

@dspreadbury No rush and no worries! Just keep me posted. And as always very much appreciate the help.

And @wcreed for clarification–I have my outputs set correctly in both Kontakt and Dorico, and the correct number show in Dorico’s mixer; however, should I have more than 5 outputs, the 6th+ output(s) in Dorico’s mixer are treated as Mono.

1 Like