Endpoint MIDI channels and the mixer

I am using the Aria multi VST, which has by default 16 stereo channels, I have configured an endpoint such that it uses three of these channel pairs. I export the endpoint, then add it to a playback template, and apply the template to the project. I still see 16 stereo pairs in the mixer with only the VST Instrument filter selected. What is it about the “Number of MIDI channels” Endpoint Setup parameter and the mixer that I am not understanding?

What do you expect to see (in the Dorico mixer)?
Could you attach an image of the mixer?

What happens right now in Dorico is that if you have 16 midi channels and 16 stereo outputs, they will all come into the mixer fixed to this configuration…In other words, you cannot currently route midi channel 3 out of output 3 & 4, or stereo pair number 2. Midi channel 3 will always come out of the third output pair (5&6). I believe that more flexible routing will be forthcoming. Having said that, in the Endpoint Setup in PLAY mode (where you assign the Expression Maps) you can chose at the bottom, how many outputs will show up in the mixer. If you are using midi channels 1 to 3 coming out of outputs 1&2, 3&4, 5&6, you can set this to 3 and that will be all the channels that will show up in the mixer. In order to use the ‘solo’ feature in Dorico, each instrument must come out of its own channel in the Dorico mixer. I hope that helps.

Grainger,

What you say is what is expected to happen if the Aria Multi-Player is properly configured. My question was whether this is what OldSkoolMark is experiencing.

Been away from my computer … thanks to you both for looking at this. Derrek is right, I just started from scratch and created Grainger’s configuration. As you can see, I have more than 3 stereo channels in the mixer.

You may already have done this (based on the results you get in the Dorico Mixer, but the Aria Multi-channel has pull-down menus to set its output channels.

outputChannels.png

I forgot to set those in the example, but I have been setting them 1/2, 3/4, 5/6. Changed that in the example to no effect. Do you have to export the endpoint, put it in a playback template and select that template to get the right number of midi channels in the mixer?

Here is the test project I have been using. Still unable to hide channels 7-16.
JabbAriaRhythm.zip (351 KB)

Configure the endpoint to hide the channels you do not want on Dorico’s Mixer.

  1. Go to the play tab.
  2. Click the endpoint setup for the instance you wish to configure.
  3. Tick the box by "Number of audio outputs to show in Mixer: Change it to 3 (so only the first three faders are applied).

In my example below, I just want the first 4 faders (8 audio channels / 4 stereo pairs…) for this String Quartet to show up on Dorico’s Mixing console…works like a charm.

P.S.

The limited endpoints can be exported for playback templates as well with Dorico 3, and they should stick.

While I haven’t tested this thoroughly with Aria specifically, I have noticed it works with HALion. Example HSSE based template where Dorico is forced to hide extra audio outputs can be found here:
https://www.steinberg.net/forums/viewtopic.php?f=246&t=169759#p974036