Engrave mode bug

Sorry for all these posts… :astonished:

Quite often when entering engrave mode Dorico stays in Gallery View with the Page View button greyed out. Bug?
EngraveModeBug.png

+1

Odd. I have reported this, but no one else had until today! I haven’t seen that behaviour since .20 but obviously it can still happen.

If you can pin down the steps that makes this happen, we would certainly be interested to know.

I can’t speak for the others, but for me it was completely random; at least it seemed so …

It sort of happens pretty random. When switching layouts it sometimes happens sometimes not, even though I do exactly the same manouvre.

Now I found it! :slight_smile:

I also tried this with a new un formatted document and it “worked” here too.
• View the score and go to Engrave mode (no problems)
• Now, when switching to a part (in Engrave Mode) the part displays in Gallery view with no option to change to Page View.

No, that’s not quite right. What do you have set as your ‘Default view type’ in Preferences? Are you using multiple tabs? Can you make a little screen capture of the steps you’re taking and post it here?

If I change the default view type to Page View it works. But when working in Write mode I’d like to have the Gallery view as my default. I can’t see why I should work in Gallery View at all in Engrave mode?

The strange thing is that the active layout (score or part) always turns into page view when entering Engrave mod, but then when switching to another (score or part), that one is in Gallery View.

I have no tabs active.

I can do a short screen video showing this if you want.

Thanks for confirming the details. I can reproduce the problem. We’ll look into fixing this.