Engrave mode: layout questions

I have a couple of questions concerning the layout of the attached. Originally this project was imported (MusicXML uncompressed) from Sibelius v.7 as a way of learning Dorico. There are two layout issues, which I don’t seem to be able to address in Engrave mode:
Firstly, I cannot manipulate the first staff to reduce the space taken up by the multirest (there is another flow, with a similarly distended single measure rest). If I select bars 1-5 to make a single system, this doesn’t respace the multirest, and actually forces more bars onto the next page! I’ve tried Note Spacing (selecting the first two systems) and then Engrave>Note Spacing>Reset Layout, which has no effect. Subsequently, Engrave>Note Spacing>Reset Selected Systems, which also has no effect.
I have altered some of the settings in Engraving Options>Rests>Spacing, but since they made no difference, they are now returned to the default settings.
Ellen Hn 5 part.png
Second issue: the whole of this flow sought to be on a single page (as it is in Sibelius - margins and staff size are the same). I’ve removed rehearsal marks (and Coda marks temporarily) in order to get a more uniform staff spacing; and tried to contain the flow on a single page, but I can’t get satisfactory staff spacing. Staff size is 4 (4.61pt/6.5mm) – I don’t want to reduce the staff size (and, as I say, it works in Sibelius). Casting Off options (Setup>Layout Options) are as default.
I’ve scoured the PDF manual, the Help menu, searched the forum, and sat through several YouTube videos, without success. What am I missing?

Thanks for advice,

Have you reset all appearance and so, as it was recommended (before 1.1) when importing from XML ? I know there has been improvement, but honestly, I do not think the problems you have should happen in Dorico, with a file created from scratch… so I feel like there are still some disturbing informations coming from the import.
https://www.steinberg.net/forums/viewtopic.php?f=246&t=107012#p587440

If this was imported prior to 1.1, I would definitely do as Marc suggests, select all and then do Edit/Reset appearance.

In Engrave, if you select the time signature, then ctrl-click the last note in bar 5 and do “Make into system”, what happens?

Also, you should be able make everything into a single frame(page) by selecting the time sign. and ctrl-clicking the last note in the piece and do Make into frame. But when you decide to force more music onto a page than Dorico thinks fit, be prepared to spend more time on manual adjustments. Reducing the staff size very slightly is probably an easier solution…

You should also be able to move the barline after the multibar rest with the new Note Spacing tools in 1.1…

Thanks to you both for your replies; I’d already taken the steps described, but am grateful to know that I hadn’t missed anything glaringly obvious; it’s great to be able to share these issues on the forum.
On further exploration, I discovered that moving the (start repeat) barline after the multirest (in Engrave) caused two system breaks to “magically” appear in Write (although they hadn’t been there previously). There’s a deal of going back and forth involved as these System Breaks keep reappearing every time the note spacing is altered. One thing that helped with the staff spacing was to go back to Setup>Layout Options>Staves and Systems>Casting Off, and change the fixed number of systems from 10 (default) to 9. Scale number of systems by frame height is then illuminated (and checked), and this allows me to incorporate the entire flow in a single frame. The attached is just by way of showing how I’ve managed to improve the layout so far. My conclusion is that there’s a good deal of tinkering needed with XML importing, but perseverance is paying off!
Ellen Hn 5 part new.png